summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild
index 6cee78706f42..4b8d5155df35 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild,v 1.1 2012/09/14 20:07:13 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs-fuse/unionfs-fuse-0.26.ebuild,v 1.2 2012/09/22 20:29:57 sping Exp $
EAPI="3"
+inherit eutils
+
+
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
HOMEPAGE="http://podgorny.cz/moin/UnionFsFuse"
@@ -17,6 +20,11 @@ IUSE=""
DEPEND="sys-fs/fuse"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-link-pthread.patch
+ epatch "${FILESDIR}"/${P}-declare-chroot.patch
+}
+
src_install() {
dodir /usr/sbin /usr/share/man/man8/ || die "dodir failed"
emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"