summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/iasl/files/iasl-20110922-as-needed.patch')
-rw-r--r--sys-power/iasl/files/iasl-20110922-as-needed.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-power/iasl/files/iasl-20110922-as-needed.patch b/sys-power/iasl/files/iasl-20110922-as-needed.patch
new file mode 100644
index 000000000000..a507f74ea9b2
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-as-needed.patch
@@ -0,0 +1,16 @@
+ tools/acpiexec/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/acpiexec/Makefile b/tools/acpiexec/Makefile
+index ba6b534..8435985 100644
+--- a/tools/acpiexec/Makefile
++++ b/tools/acpiexec/Makefile
+@@ -269,7 +269,7 @@ CWARNINGFLAGS += \
+ # Rules
+ #
+ $(PROG) : $(OBJECTS)
+- $(CC) $(LDFLAGS) $(OBJECTS) -o $(PROG)
++ $(CC) $(OBJECTS) $(LDFLAGS) -o $(PROG)
+ $(COPYPROG)
+
+ %.o : %.c $(HEADERS) $(ACPICA_HEADERS)