summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/atop/atop-2.2.ebuild')
-rw-r--r--sys-process/atop/atop-2.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-process/atop/atop-2.2.ebuild b/sys-process/atop/atop-2.2.ebuild
new file mode 100644
index 000000000000..a175fe507a63
--- /dev/null
+++ b/sys-process/atop/atop-2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-2.2.ebuild,v 1.1 2015/06/25 21:13:42 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV//_p/-}
+MY_P=${PN}-${MY_PV}-3
+
+DESCRIPTION="Resource-specific view of processes"
+HOMEPAGE="http://www.atoptool.nl/"
+SRC_URI="http://www.atoptool.nl/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-process/acct
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2-build.patch
+ tc-export CC PKG_CONFIG
+ sed -i 's: root : :' atop.cronsysv || die #191926
+ # prefixify
+ sed -i "s:/\(usr\|etc\|var\):${EPREFIX}/\1:g" Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" genericinstall
+ # useless -${PV} copies ?
+ rm -f "${ED}"/usr/bin/atop*-${MY_PV}
+ newinitd "${FILESDIR}"/${PN}.rc-r1 ${PN}
+ newinitd "${FILESDIR}"/atopacct.rc atopacct
+ dodoc atop.cronsysv AUTHOR ChangeLog README
+}