summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xfd')
-rw-r--r--x11-apps/xfd/ChangeLog7
-rw-r--r--x11-apps/xfd/files/digest-xfd-0.99.11
-rw-r--r--x11-apps/xfd/xfd-0.99.1.ebuild23
3 files changed, 30 insertions, 1 deletions
diff --git a/x11-apps/xfd/ChangeLog b/x11-apps/xfd/ChangeLog
index 862460959d9d..57dd975012f9 100644
--- a/x11-apps/xfd/ChangeLog
+++ b/x11-apps/xfd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/ChangeLog,v 1.4 2005/09/28 03:01:36 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/ChangeLog,v 1.5 2005/10/20 00:45:22 spyderous Exp $
+
+*xfd-0.99.1 (20 Oct 2005)
+
+ 20 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>; +xfd-0.99.1.ebuild:
+ Bump for 7.0 RC1.
28 Sep 2005; Donnie Berkholz <spyderous@gentoo.org>; xfd-0.99.0.ebuild:
Add note about xprint being optional as of today's CVS.
diff --git a/x11-apps/xfd/files/digest-xfd-0.99.1 b/x11-apps/xfd/files/digest-xfd-0.99.1
new file mode 100644
index 000000000000..b8aa01cec904
--- /dev/null
+++ b/x11-apps/xfd/files/digest-xfd-0.99.1
@@ -0,0 +1 @@
+MD5 9a4ead5de7e808e80a422eda093cc018 xfd-0.99.1.tar.bz2 86596
diff --git a/x11-apps/xfd/xfd-0.99.1.ebuild b/x11-apps/xfd/xfd-0.99.1.ebuild
new file mode 100644
index 000000000000..f4c1100f4fa4
--- /dev/null
+++ b/x11-apps/xfd/xfd-0.99.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/xfd-0.99.1.ebuild,v 1.1 2005/10/20 00:45:22 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfd application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="=media-libs/freetype-2*
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}