summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/fox/fox-1.2.4.ebuild')
-rw-r--r--x11-libs/fox/fox-1.2.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/fox/fox-1.2.4.ebuild b/x11-libs/fox/fox-1.2.4.ebuild
new file mode 100644
index 000000000000..7861e1f028e1
--- /dev/null
+++ b/x11-libs/fox/fox-1.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.2.4.ebuild,v 1.1 2004/06/13 01:59:12 pyrania Exp $
+
+IUSE="cups debug opengl"
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.fox-toolkit.org"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ myconf="$myconf `use_enable cups debug`" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}