summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/vte-0.30.1.ebuild48
-rw-r--r--x11-libs/vte/vte-0.32.0.ebuild (renamed from x11-libs/vte/vte-0.30.1-r2.ebuild)14
3 files changed, 16 insertions, 54 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 59b0786b947b..460785d546db 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.315 2012/03/25 17:58:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.316 2012/03/27 04:47:11 tetromino Exp $
+
+*vte-0.32.0 (27 Mar 2012)
+
+ 27 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org> -vte-0.30.1.ebuild,
+ -vte-0.30.1-r2.ebuild, +vte-0.32.0.ebuild:
+ Version bump with gtk+-3.4 support and urxvt mouse tracking mode. Drop old.
25 Mar 2012; Raúl Porcel <armin76@gentoo.org> vte-0.28.2-r202.ebuild:
alpha/ia64/sh/sparc stable wrt #393007
diff --git a/x11-libs/vte/vte-0.30.1.ebuild b/x11-libs/vte/vte-0.30.1.ebuild
deleted file mode 100644
index 92d2c4c19ca3..000000000000
--- a/x11-libs/vte/vte-0.30.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1.ebuild,v 1.1 2011/10/21 19:56:15 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="GNOME terminal widget"
-HOMEPAGE="http://git.gnome.org/browse/vte"
-
-LICENSE="LGPL-2"
-SLOT="2.90"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc glade +introspection"
-
-PDEPEND="x11-libs/gnome-pty-helper"
-RDEPEND=">=dev-libs/glib-2.26:2
- >=x11-libs/gtk+-3.1.9:3[introspection?]
- >=x11-libs/pango-1.22.0
-
- sys-libs/ncurses
- x11-libs/libX11
- x11-libs/libXft
-
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.9
- sys-devel/gettext
- doc? ( >=dev-util/gtk-doc-1.13 )"
-
-pkg_setup() {
- # Python bindings are via gobject-introspection
- # Ex: from gi.repository import Vte
- G2CONF="${G2CONF}
- --disable-gnome-pty-helper
- --disable-deprecation
- --disable-maintainer-mode
- --disable-static
- $(use_enable debug)
- $(use_enable glade glade-catalogue)
- $(use_enable introspection)"
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-}
diff --git a/x11-libs/vte/vte-0.30.1-r2.ebuild b/x11-libs/vte/vte-0.32.0.ebuild
index 80a32dd16446..9a917cf577cc 100644
--- a/x11-libs/vte/vte-0.30.1-r2.ebuild
+++ b/x11-libs/vte/vte-0.32.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1-r2.ebuild,v 1.1 2011/11/18 08:48:37 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.32.0.ebuild,v 1.1 2012/03/27 04:47:11 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -17,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-
IUSE="debug doc glade +introspection"
PDEPEND="x11-libs/gnome-pty-helper"
-RDEPEND=">=dev-libs/glib-2.26:2
+RDEPEND=">=dev-libs/glib-2.31.13:2
>=x11-libs/gtk+-3.1.9:3[introspection?]
>=x11-libs/pango-1.22.0
@@ -36,10 +36,9 @@ DEPEND="${RDEPEND}
pkg_setup() {
# Python bindings are via gobject-introspection
# Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
G2CONF="${G2CONF}
- --disable-gnome-pty-helper
--disable-deprecation
- --disable-maintainer-mode
--disable-static
$(use_enable debug)
$(use_enable glade glade-catalogue)
@@ -53,3 +52,8 @@ src_prepare() {
gnome2_src_prepare
}
+
+src_install() {
+ gnome2_src_install
+ rm -v "${ED}usr/libexec/gnome-pty-helper" || die
+}