summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/glproto/glproto-1.4.2.ebuild')
-rw-r--r--x11-proto/glproto/glproto-1.4.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-proto/glproto/glproto-1.4.2.ebuild b/x11-proto/glproto/glproto-1.4.2.ebuild
new file mode 100644
index 000000000000..532d2eb9787b
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.2.ebuild,v 1.1 2005/12/17 21:04:32 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-admin/eselect-opengl"
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}