summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/afterstep/afterstep-2.00.05.ebuild')
-rw-r--r--x11-wm/afterstep/afterstep-2.00.05.ebuild29
1 files changed, 24 insertions, 5 deletions
diff --git a/x11-wm/afterstep/afterstep-2.00.05.ebuild b/x11-wm/afterstep/afterstep-2.00.05.ebuild
index c65524d5f179..fe1c7c168739 100644
--- a/x11-wm/afterstep/afterstep-2.00.05.ebuild
+++ b/x11-wm/afterstep/afterstep-2.00.05.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.00.05.ebuild,v 1.6 2005/08/23 18:55:31 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.00.05.ebuild,v 1.7 2006/02/13 21:14:38 spock Exp $
inherit flag-o-matic
@@ -13,14 +13,33 @@ SLOT="0"
KEYWORDS="ppc sparc x86"
IUSE="debug gif jpeg mmx nls png tiff xinerama"
-DEPEND="virtual/libc
- virtual/x11
+RDEPEND="virtual/libc
media-libs/freetype
debug? ( !ppc? ( dev-util/efence ) )
png? ( >=media-libs/libpng-1.2.5 )
jpeg? ( >=media-libs/jpeg-6b )
gif? ( >=media-libs/giflib-4.1.0 )
- tiff? ( >=media-libs/tiff-3.5.7 )"
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
S="${WORKDIR}/AfterStep-${PV}"