summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/cwm/cwm-20110726.ebuild')
-rw-r--r--x11-wm/cwm/cwm-20110726.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-20110726.ebuild b/x11-wm/cwm/cwm-20110726.ebuild
new file mode 100644
index 000000000000..417e55dcbe2a
--- /dev/null
+++ b/x11-wm/cwm/cwm-20110726.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-20110726.ebuild,v 1.1 2011/08/04 22:27:34 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ export LDADD="${LDFLAGS}"
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}