aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-12-15 18:18:07 -0800
committerSteve Arnold <nerdboy@gentoo.org>2017-12-15 18:18:07 -0800
commit8a65614995548f776fc5819780f15b4ab3e3ed29 (patch)
treef3d1d75e3f27382ffe0d487e2a75f797fc7d81c5
parentcrossdev-examples.txt: add mipsel hardened musl example, update (diff)
downloadarm-8a65614995548f776fc5819780f15b4ab3e3ed29.tar.gz
arm-8a65614995548f776fc5819780f15b4ab3e3ed29.tar.bz2
arm-8a65614995548f776fc5819780f15b4ab3e3ed29.zip
armv7multi-sources: add misc (recent) kernel versions
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--sys-kernel/armv7multi-sources/armv7multi-sources-4.11.12-r1.ebuild90
-rw-r--r--sys-kernel/armv7multi-sources/armv7multi-sources-4.12.14-r3.ebuild90
-rw-r--r--sys-kernel/armv7multi-sources/armv7multi-sources-4.14.2-r1.ebuild90
3 files changed, 270 insertions, 0 deletions
diff --git a/sys-kernel/armv7multi-sources/armv7multi-sources-4.11.12-r1.ebuild b/sys-kernel/armv7multi-sources/armv7multi-sources-4.11.12-r1.ebuild
new file mode 100644
index 0000000..57b9fb6
--- /dev/null
+++ b/sys-kernel/armv7multi-sources/armv7multi-sources-4.11.12-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+ETYPE="sources"
+K_DEFCONFIG="gentoo-armv7multi_defconfig"
+UNIPATCH_STRICTORDER="1"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="5"
+K_DEBLOB_AVAILABLE="0"
+K_KDBUS_AVAILABLE="1"
+
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+inherit versionator
+MY_PR="armv7-x${PR/r/}"
+EXTRAVERSION="-${MY_PR}"
+MY_P="${OKV}-${MY_PR}"
+
+MULTI_PATCH="patch-${MY_P}.diff"
+MULTI_CONFIG="defconfig"
+MULTI_URI="https://rcn-ee.com/deb/xenial-armhf/v${MY_P}"
+M_PATCH_URI="${MULTI_URI}/${MULTI_PATCH}.xz"
+M_CONFIG_URI="${MULTI_URI}/${MULTI_CONFIG}"
+
+KEYWORDS="~arm"
+HOMEPAGE="https://eewiki.net/display/linuxonarm/Udoo"
+
+DESCRIPTION="Full sources for ${OKV} kernel plus gentoo and various ARM/iMX device patches"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${GENPATCHES_URI}
+ imx? ( ${M_PATCH_URI}
+ ${M_CONFIG_URI} -> ${K_DEFCONFIG} )"
+
+IUSE="experimental +imx"
+
+K_EXTRAELOG="This is the bleeding-edge patch set on full gentoo-sources
+kernel from LinuxOnArm maintainer Robert C Nelson. Intended mainly
+for i.MX-based boards like Wand or Udoo (use bone-sources for building
+a beaglebone kernel). A copy of the latest config has been installed as
+${K_DEFCONFIG}. If you are reading this, you know what to do..."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+src_unpack() {
+ # need to unpack manually due to patch reqs below
+ use imx && unpack ${MULTI_PATCH}.xz
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ # We can't use unipatch or epatch here due to the git binary
+ # diffs that always cause dry-run errors (even with --force).
+ # That is okay since this is not intended for beaglebone.
+
+ if use imx ; then
+ ebegin "Applying ${MULTI_PATCH}"
+ patch -p1 "${WORKDIR}"/${MULTI_PATCH}
+ eend $? || return
+ fi
+
+ use imx && update_config
+
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
+
+update_config() {
+ cp -f "${DISTDIR}"/${K_DEFCONFIG} "${S}"/arch/arm/configs/ \
+ || die "failed to install ${K_DEFCONFIG}!"
+}
+
diff --git a/sys-kernel/armv7multi-sources/armv7multi-sources-4.12.14-r3.ebuild b/sys-kernel/armv7multi-sources/armv7multi-sources-4.12.14-r3.ebuild
new file mode 100644
index 0000000..4e9ef46
--- /dev/null
+++ b/sys-kernel/armv7multi-sources/armv7multi-sources-4.12.14-r3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+ETYPE="sources"
+K_DEFCONFIG="gentoo-armv7multi_defconfig"
+UNIPATCH_STRICTORDER="1"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="15"
+K_DEBLOB_AVAILABLE="0"
+K_KDBUS_AVAILABLE="1"
+
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+inherit versionator
+MY_PR="armv7-x${PR/r/}"
+EXTRAVERSION="-${MY_PR}"
+MY_P="${OKV}-${MY_PR}"
+
+MULTI_PATCH="patch-${MY_P}.diff"
+MULTI_CONFIG="defconfig"
+MULTI_URI="https://rcn-ee.com/deb/xenial-armhf/v${MY_P}"
+M_PATCH_URI="${MULTI_URI}/${MULTI_PATCH}.xz"
+M_CONFIG_URI="${MULTI_URI}/${MULTI_CONFIG}"
+
+KEYWORDS="~arm"
+HOMEPAGE="https://eewiki.net/display/linuxonarm/Udoo"
+
+DESCRIPTION="Full sources for ${OKV} kernel plus gentoo and various ARM/iMX device patches"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${GENPATCHES_URI}
+ imx? ( ${M_PATCH_URI}
+ ${M_CONFIG_URI} -> ${K_DEFCONFIG} )"
+
+IUSE="+imx"
+
+K_EXTRAELOG="This is the bleeding-edge patch set on full gentoo-sources
+kernel from LinuxOnArm maintainer Robert C Nelson. Intended mainly
+for i.MX-based boards like Wand or Udoo (use bone-sources for building
+a beaglebone kernel). A copy of the latest config has been installed as
+${K_DEFCONFIG}. If you are reading this, you know what to do..."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+src_unpack() {
+ # need to unpack manually due to patch reqs below
+ use imx && unpack ${MULTI_PATCH}.xz
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ # We can't use unipatch or epatch here due to the git binary
+ # diffs that always cause dry-run errors (even with --force).
+ # That is okay since this is not intended for beaglebone.
+
+ if use imx ; then
+ ebegin "Applying ${MULTI_PATCH}"
+ patch -p1 "${WORKDIR}"/${MULTI_PATCH}
+ eend $? || return
+ fi
+
+ use imx && update_config
+
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
+
+update_config() {
+ cp -f "${DISTDIR}"/${K_DEFCONFIG} "${S}"/arch/arm/configs/ \
+ || die "failed to install ${K_DEFCONFIG}!"
+}
+
diff --git a/sys-kernel/armv7multi-sources/armv7multi-sources-4.14.2-r1.ebuild b/sys-kernel/armv7multi-sources/armv7multi-sources-4.14.2-r1.ebuild
new file mode 100644
index 0000000..7d4e2f3
--- /dev/null
+++ b/sys-kernel/armv7multi-sources/armv7multi-sources-4.14.2-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+ETYPE="sources"
+K_DEFCONFIG="gentoo-armv7multi_defconfig"
+UNIPATCH_STRICTORDER="1"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+K_DEBLOB_AVAILABLE="0"
+K_KDBUS_AVAILABLE="1"
+
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+inherit versionator
+MY_PR="armv7-x${PR/r/}"
+EXTRAVERSION="-${MY_PR}"
+MY_P="${OKV}-${MY_PR}"
+
+MULTI_PATCH="patch-${MY_P}.diff"
+MULTI_CONFIG="defconfig"
+MULTI_URI="https://rcn-ee.com/deb/xenial-armhf/v${MY_P}"
+M_PATCH_URI="${MULTI_URI}/${MULTI_PATCH}.xz"
+M_CONFIG_URI="${MULTI_URI}/${MULTI_CONFIG}"
+
+KEYWORDS="~arm"
+HOMEPAGE="https://eewiki.net/display/linuxonarm/Udoo"
+
+DESCRIPTION="Full sources for ${OKV} kernel plus gentoo and various ARM/iMX device patches"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${GENPATCHES_URI}
+ imx? ( ${M_PATCH_URI}
+ ${M_CONFIG_URI} -> ${K_DEFCONFIG} )"
+
+IUSE="+imx"
+
+K_EXTRAELOG="This is the bleeding-edge patch set on full gentoo-sources
+kernel from LinuxOnArm maintainer Robert C Nelson. Intended mainly
+for i.MX-based boards like Wand or Udoo (use bone-sources for building
+a beaglebone kernel). A copy of the latest config has been installed as
+${K_DEFCONFIG}. If you are reading this, you know what to do..."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+src_unpack() {
+ # need to unpack manually due to patch reqs below
+ use imx && unpack ${MULTI_PATCH}.xz
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ # We can't use unipatch or epatch here due to the git binary
+ # diffs that always cause dry-run errors (even with --force).
+ # That is okay since this is not intended for beaglebone.
+
+ if use imx ; then
+ ebegin "Applying ${MULTI_PATCH}"
+ patch -p1 "${WORKDIR}"/${MULTI_PATCH}
+ eend $? || return
+ fi
+
+ use imx && update_config
+
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
+
+update_config() {
+ cp -f "${DISTDIR}"/${K_DEFCONFIG} "${S}"/arch/arm/configs/ \
+ || die "failed to install ${K_DEFCONFIG}!"
+}
+