aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-07-27 12:02:26 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-07-27 12:02:26 -0700
commitec815780f96c3c5e24982e8c08eda7ed3704f136 (patch)
tree2bde3de673015d17c5c3ef3062c58acf78f3e270 /x11-drivers
parentadded test libump ebuild for gles2 supported acceleration (diff)
downloadarm-ec815780f96c3c5e24982e8c08eda7ed3704f136.tar.gz
arm-ec815780f96c3c5e24982e8c08eda7ed3704f136.tar.bz2
arm-ec815780f96c3c5e24982e8c08eda7ed3704f136.zip
updated armsoc ebuilds with alternate open source upstream
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-armsoc/Manifest4
-rw-r--r--x11-drivers/xf86-video-armsoc/files/xf86-video-armsoc-implicit_declaration.patch13
-rw-r--r--x11-drivers/xf86-video-armsoc/xf86-video-armsoc-0.6.0-r19.ebuild44
-rw-r--r--x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.4731.81.ebuild37
-rw-r--r--x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.ebuild60
5 files changed, 134 insertions, 24 deletions
diff --git a/x11-drivers/xf86-video-armsoc/Manifest b/x11-drivers/xf86-video-armsoc/Manifest
index 0f5324c..2342b39 100644
--- a/x11-drivers/xf86-video-armsoc/Manifest
+++ b/x11-drivers/xf86-video-armsoc/Manifest
@@ -1,3 +1 @@
-AUX 0001-Import-patch-from-Marcin.patch 13238 SHA256 58b4d31abd7c3bf79e9d8ce8d13d089fbf40d41c75bbf917df32d9a85029e147 SHA512 86f1396ab74b26ee93a1090ab06be0d2eb012805c2dcbf1a7ecd671dbb0d5be5b1d1bb5d0f3e1c59bd686aaac0e38a49da98c1c9c3dc4ad6bb7ca7a581d6ceb6 WHIRLPOOL 6b486ae6b24036403291a3b095fc28897dd28f2508182986e28aa0a1a9f5761413e57c03c71dfbd6840959e8cf1bb35c2dfaa9221bf455a3cc4e11e811593a13
-AUX remove-mibstore-header-include.patch 638 SHA256 bb52aed4eca3cc7b358c77302ada1452845fba3364fbe064d9fe114c5708ed77 SHA512 8bad45bb731c1d1cc7d6ccf3b62a40bdbb4683f7097f5c780a665f82559d6716b3b9475b412f5042654625ccdfa4d164b6fa3bd9d26b7bea5dd18b9f483cf664 WHIRLPOOL 04ad57ee42362190921e807d4ce25096a980edac1c3bf0fdbbcd40c9a1b6fa67f3de87928d0e8f12a419c63122111b9e944cddc43637e2f7e49a1f8764f90f2a
-EBUILD xf86-video-armsoc-9999.ebuild 879 SHA256 0e5053573dc4ae27c16190c2882fb9685ef0ea98b113c0f6025a03f16ecf535c SHA512 2dcac1fbe4835273ed1e97013f077b0d7b868fecfed62b04216e01b10c9e857b1857e4460827195da7e2eb1fbe07ebd52a975765ab62c6e7367e3810fe712701 WHIRLPOOL 1e7b3f2d6452b75059dc7b4ae322fc9b6773fa1c68b15981b170ccdf1c5f7a09c908a93fa98d65e9c067ea18a8a54728e7b74d1e16e8fceac4a8eb9b083820aa
+DIST xf86-video-armsoc-0.6.0-r19.tar.gz 50938 SHA256 4d3b909fdc623c1f40fdb708931522cf6961dca4de0745751fe07f225959ffa3 SHA512 c3e59be74c3b4d43f2dcf5102ac0eb3284a5fd15195db235c5abc55c97039629415b99c40a972b5756454c4609a3ac55f49fc237d8587d9940aef7f0636d8284 WHIRLPOOL 0a1ac3980b94298b4e4f485083493eb981b41ec4f7c6fc6e965cc162cc4076ae0ee4fcb1c47189ef0c544e83fd5931bb974929fda4e872566600c56f7f37c840
diff --git a/x11-drivers/xf86-video-armsoc/files/xf86-video-armsoc-implicit_declaration.patch b/x11-drivers/xf86-video-armsoc/files/xf86-video-armsoc-implicit_declaration.patch
new file mode 100644
index 0000000..2005010
--- /dev/null
+++ b/x11-drivers/xf86-video-armsoc/files/xf86-video-armsoc-implicit_declaration.patch
@@ -0,0 +1,13 @@
+--- src/drmmode_display.c.orig 2015-07-27 00:49:45.944676448 -0700
++++ src/drmmode_display.c 2015-07-27 00:52:23.438688568 -0700
+@@ -51,6 +51,10 @@
+ #include <libudev.h>
+ #include "drmmode_driver.h"
+
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
++
+ struct drmmode_cursor_rec {
+ /* hardware cursor: */
+ struct armsoc_bo *bo;
diff --git a/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-0.6.0-r19.ebuild b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-0.6.0-r19.ebuild
new file mode 100644
index 0000000..6b33d9d
--- /dev/null
+++ b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-0.6.0-r19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+XORG_DRI="always"
+XORG_EAUTORECONF="yes"
+XORG_CONFIGURE_OPTIONS="--with-drmmode=exynos"
+
+inherit autotools xorg-2 versionator
+
+MY_PR="1endless9"
+MY_PV="v${PV}-${MY_PR}"
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/mdrjr/xf86-video-armsoc/archive/v${PV}-${MY_PR}.tar.gz -> ${P}-${PR}.tar.gz"
+ KEYWORDS="~arm"
+ S="${WORKDIR}/${P}-${MY_PR}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdrjr/xf86-video-armsoc.git
+ git@github.com:mdrjr/xf86-video-armsoc.git"
+ ## release branch for github tarballs: r4p0-umplock
+ ## alternate 5422 branch is more active: 5422_r5p1
+ EGIT_BRANCH="5422_r5p1"
+fi
+
+DESCRIPTION="Open-source X.org graphics driver for ARM graphics"
+HOMEPAGE="https://github.com/mdrjr/xf86-video-armsoc"
+LICENSE="MIT"
+
+RDEPEND=">=x11-base/xorg-server-1.9
+ !x11-drivers/mali-drivers"
+
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+# Best way to jam this into the config parameter?
+#IUSE="exynos pl111"
+
+AUTOTOOLS_IN_SOURCE_BUILD="yes"
+AUTOTOOLS_AUTORECONF="yes"
+
diff --git a/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.4731.81.ebuild b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.4731.81.ebuild
new file mode 100644
index 0000000..34d6aab
--- /dev/null
+++ b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.4731.81.ebuild
@@ -0,0 +1,37 @@
+# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
+# Distributed under the terms of the GNU Public License v2
+
+EAPI="5"
+
+EGIT_REPO_URI="https://chromium.googlesource.com/chromiumos/third_party/${PN}.git"
+#EGIT_REPO_URI="git://git.linaro.org/arm/xorg/driver/xf86-video-armsoc.git"
+#EGIT_COMMIT="8613894e87e74a4d21ba78b8a50bb3733e53b93d"
+EGIT_BRANCH="factory-daisy-4731.81.B"
+
+## This can use a hefty patch for modern xorg (eg, 1.17 or so) especially
+## since the old commit above doesn't even clone...
+
+XORG_DRI="always"
+XORG_EAUTORECONF="yes"
+XORG_CONFIGURE_OPTIONS="--with-driver=exynos"
+
+inherit xorg-2 git-r3 eutils flag-o-matic
+
+DESCRIPTION="X.Org driver for ARM devices"
+
+RDEPEND=">=x11-base/xorg-server-1.9
+ !x11-drivers/mali-drivers"
+
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+# epatch "${FILESDIR}"/0001-Import-patch-from-Marcin.patch
+ epatch "${FILESDIR}"/remove-mibstore-header-include.patch
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ append-cflags -Wno-error
+ xorg-2_src_configure
+}
diff --git a/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.ebuild b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.ebuild
index 6ab5719..7622c55 100644
--- a/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.ebuild
+++ b/x11-drivers/xf86-video-armsoc/xf86-video-armsoc-9999.ebuild
@@ -1,21 +1,34 @@
-# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
-# Distributed under the terms of the GNU Public License v2
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
-EAPI="5"
-
-EGIT_REPO_URI="https://chromium.googlesource.com/chromiumos/third_party/${PN}.git"
-#EGIT_REPO_URI="git://git.linaro.org/arm/xorg/driver/xf86-video-armsoc.git"
-EGIT_COMMIT="8613894e87e74a4d21ba78b8a50bb3733e53b93d"
+EAPI=5
XORG_DRI="always"
XORG_EAUTORECONF="yes"
-XORG_CONFIGURE_OPTIONS="--with-driver=exynos"
-
-inherit xorg-2 git-r3 eutils flag-o-matic
-
-DESCRIPTION="X.Org driver for ARM devices"
-
-KEYWORDS="-* ~arm"
+XORG_CONFIGURE_OPTIONS="--with-drmmode=exynos --disable-selective-werror"
+
+inherit autotools xorg-2 flag-o-matic
+
+MY_PR="1endless9"
+MY_PV="v${PV}-${MY_PR}"
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/mdrjr/xf86-video-armsoc/archive/v${PV}-${MY_PR}.tar.gz -> ${P}-${PR}.tar.gz"
+ KEYWORDS="~arm"
+ S="${WORKDIR}/${P}-${MY_PR}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdrjr/xf86-video-armsoc.git
+ git@github.com:mdrjr/xf86-video-armsoc.git"
+ ## release branch for github tarballs: r4p0-umplock
+ ## alternate 5422 branch is more active: 5422_r5p1
+ EGIT_BRANCH="5422_r5p1"
+fi
+
+DESCRIPTION="Open-source X.org graphics driver for ARM graphics"
+HOMEPAGE="https://github.com/mdrjr/xf86-video-armsoc"
+LICENSE="MIT"
RDEPEND=">=x11-base/xorg-server-1.9
!x11-drivers/mali-drivers"
@@ -23,13 +36,18 @@ RDEPEND=">=x11-base/xorg-server-1.9
DEPEND="${RDEPEND}
x11-proto/xextproto"
+# Best way to jam this into the config parameter?
+#IUSE="exynos pl111"
+
+AUTOTOOLS_IN_SOURCE_BUILD="yes"
+AUTOTOOLS_AUTORECONF="yes"
+
src_prepare() {
-# epatch "${FILESDIR}"/0001-Import-patch-from-Marcin.patch
- epatch "${FILESDIR}"/remove-mibstore-header-include.patch
- xorg-2_src_prepare
-}
+ sed -i -e "s|ERROR_CFLAGS = -Werror|ERROR_CFLAGS = |" \
+ "${S}"/Makefile.am "${S}"/src/Makefile.am \
+ || die "could not tweak makefile.am!"
-src_configure() {
- append-cflags -Wno-error
- xorg-2_src_configure
+ epatch "${FILESDIR}"/${PN}-implicit_declaration.patch
+
+ xorg-2_src_prepare
}