summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2015-02-23 18:55:11 +0100
committerSebastian Pipping <sebastian@pipping.org>2015-02-23 21:35:36 +0100
commitdf04785a1012976b8719f9f8c4cb156ef49dc390 (patch)
tree94c3f60a2539e2304a3996ad44745fa62df3792b /media-gfx/blender/blender-2.31a.ebuild
parentmetadata/layout.conf (diff)
downloadblender-gentoo-logo-df04785a1012976b8719f9f8c4cb156ef49dc390.tar.gz
blender-gentoo-logo-df04785a1012976b8719f9f8c4cb156ef49dc390.tar.bz2
blender-gentoo-logo-df04785a1012976b8719f9f8c4cb156ef49dc390.zip
media-gfx/blender: Resurrect 2.31a from CVS
media-gfx/blender/blender-2.31a.ebuild (current latest) http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/blender/blender-2.31a.ebuild?revision=1.9 media-gfx/blender/files/configure-fix-2.31a.patch (current latest) http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/blender/files/configure-fix-2.31a.patch?revision=1.2 media-gfx/blender/files/blender.desktop (NOT current latest) http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/blender/files/blender.desktop?revision=1.1.1.1 media-gfx/blender/files/blender-2.31a-plugins.patch (current latest) http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/blender/files/blender-2.31a-plugins.patch?revision=1.2 media-gfx/blender/files/blender.png (NOT current latest) http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/blender/files/blender.png?revision=1.1
Diffstat (limited to 'media-gfx/blender/blender-2.31a.ebuild')
-rw-r--r--media-gfx/blender/blender-2.31a.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/blender/blender-2.31a.ebuild b/media-gfx/blender/blender-2.31a.ebuild
new file mode 100644
index 0000000..9bce6c0
--- /dev/null
+++ b/media-gfx/blender/blender-2.31a.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/Attic/blender-2.31a.ebuild,v 1.9 2005/01/03 12:41:13 lu_zero dead $
+
+inherit flag-o-matic eutils
+replace-flags -march=pentium4 -march=pentium3
+
+IUSE="sdl jpeg png mozilla truetype static"
+#IUSE="${IUSE} blender-game blender-plugin"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="|| (GPL-2 BL)"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/x11
+ blender-game? ( dev-games/ode )
+ sdl? ( media-libs/libsdl )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ mozilla? ( net-www/mozilla )
+ truetype? ( >=media-libs/freetype-2.0 )
+ fmod? ( media-libs/fmod )
+ >=media-libs/openal-20020127
+ >=media-libs/libsdl-1.2
+ >=media-libs/libvorbis-1.0
+ >=dev-libs/openssl-0.9.6"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/configure-fix-${PV}.patch
+ epatch ${FILESDIR}/${P}-plugins.patch
+ cd ${S}/release/plugins
+ chmod 755 bmake
+}
+
+
+src_compile() {
+ local myconf=""
+
+ # SDL Support
+ use sdl && myconf="${myconf} --with-sdl=/usr"
+ # || myconf="${myconf} --without-sdl"
+
+ # Jpeg support
+ use jpeg && myconf="${myconf} --with-libjpeg=/usr"
+
+ # PNG Support
+ use png && myconf="${myconf} --with-libpng=/usr"
+
+ # ./configure points at the wrong mozilla directories and will fail
+ # with this enabled. (A simple patch should take care of this)
+ use mozilla && myconf="${myconf} --with-mozilla=/usr"
+
+ # TrueType support (For text objects)
+ use truetype && myconf="${myconf} --with-freetype2=/usr"
+
+ # Build Staticly
+ use static && myconf="${myconf} --enable-blenderstatic"
+
+ # Build the game engine
+ # use blender-game && myconf="${myconf} --enable-gameblender"
+
+ # Build the plugin (Will fail, requires gameblender)
+ # use blender-plugin && myconf="${myconf} --enable-blenderplugin"
+
+ econf ${myconf} || die
+ emake || die
+ cd ${S}/release/plugins
+ emake || die
+
+}
+
+src_install() {
+ einstall || die
+
+ exeinto /usr/lib/${PN}/textures
+ doexe ${S}/release/plugins/texture/*.so
+ exeinto /usr/lib/${PN}/sequences
+ doexe ${S}/release/plugins/sequence/*.so
+
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/${PN}.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+
+ dodoc COPYING INSTALL README release_2*
+
+}