aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-06-21 17:07:38 +0300
committerlayman <layman@localhost>2015-06-21 17:07:38 +0300
commitc6dcfdda4577cf328b6edf3560ce29b37909db78 (patch)
tree9345805ab79cbbf6a4b30d6bcf4ab649a5643192 /app-shells
parentresolve issue #62 (diff)
downloaddotnet-c6dcfdda4577cf328b6edf3560ce29b37909db78.tar.gz
dotnet-c6dcfdda4577cf328b6edf3560ce29b37909db78.tar.bz2
dotnet-c6dcfdda4577cf328b6edf3560ce29b37909db78.zip
ebuild for pash
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pash/Manifest1
-rw-r--r--app-shells/pash/pash-0.0-r20150618.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/pash/Manifest b/app-shells/pash/Manifest
new file mode 100644
index 0000000..fd1354b
--- /dev/null
+++ b/app-shells/pash/Manifest
@@ -0,0 +1 @@
+DIST pash-0.0-r20150618.zip 4707302 SHA256 4b21db74a6c352bf6c56d656ca1514c6ebf509dd2c27983135b2359a6e87e01c SHA512 25212d55c4f40aed674e198fe6246986449b300df66a915494de0f3b6a9a8ac12dba30bd74458f0af2b59a4341acf303554e00dab99840386ad6e5bed7a81ea3 WHIRLPOOL 853060b9c141f93530ce8eb3479dc9474d4cd9e3f41c48531ba84c6fe11304f38ad8f61386e38d490f15c062403c0ed18139f72cfd23730f12695888082b750f
diff --git a/app-shells/pash/pash-0.0-r20150618.ebuild b/app-shells/pash/pash-0.0-r20150618.ebuild
new file mode 100644
index 0000000..1cb27fc
--- /dev/null
+++ b/app-shells/pash/pash-0.0-r20150618.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit dotnet
+
+DESCRIPTION="An Open Source reimplementation of Windows PowerShell"
+
+LICENSE="BSD || ( GPL )" # LICENSE syntax is defined in https://wiki.gentoo.org/wiki/GLEP:23
+
+SLOT="0"
+
+IUSE="debug"
+
+PROJECTNAME="Pash"
+HOMEPAGE="https://github.com/Pash-Project/${PROJECTNAME}"
+EGIT_COMMIT="33ffa8c6172175e678310598adcc261a4e3b22a0"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.zip -> ${P}-${PR}.zip"
+
+KEYWORDS="~x86 ~amd64 ~ppc"
+DEPEND="|| ( >=dev-lang/mono-3.12.0 <dev-lang/mono-9999 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PROJECTNAME}-${EGIT_COMMIT}"
+
+
+METAFILETOBUILD=${PROJECTNAME}.proj
+
+src_compile() {
+ # https://bugzilla.xamarin.com/show_bug.cgi?id=9340
+ if use debug; then
+ exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
+ else
+ exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
+ fi
+}
+
+src_install() {
+ elog "Installing assemblies"
+ insinto /usr/lib/pash/
+ doins ${S}/Source/PashConsole/bin/Release/Pash.exe
+ doins ${S}/Source/PashConsole/bin/Release/*.dll
+ if use debug; then
+ doins ${S}/Source/PashConsole/bin/Release/*.mdb
+ fi
+ make_wrapper pash "mono /usr/lib/pash/Pash.exe"
+}