aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather <Heather@cynede.net>2013-09-19 16:39:41 +0400
committerHeather <Heather@cynede.net>2013-09-23 16:41:25 +0400
commite0100e8c9b071caae7256e06437d5bb0f59eea0f (patch)
tree5b9e7096b37aec44cfeddcf90235f4b6f24e5c00 /net-irc
parentAdd mono 3.2.3 ebuild (diff)
downloaddotnet-e0100e8c9b071caae7256e06437d5bb0f59eea0f.tar.gz
dotnet-e0100e8c9b071caae7256e06437d5bb0f59eea0f.tar.bz2
dotnet-e0100e8c9b071caae7256e06437d5bb0f59eea0f.zip
correct header
get mozroots before src_compile maybe? repair NuGet 9999 NuGet fix move seding to src_install remove postinst from fsharp fix wrappers db4o for .NET smuxi 9999 fixes unmask log4net for 9999 fix smuxi 9999
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/smuxi/smuxi-0.9.ebuild7
-rw-r--r--net-irc/smuxi/smuxi-9999.ebuild43
2 files changed, 29 insertions, 21 deletions
diff --git a/net-irc/smuxi/smuxi-0.9.ebuild b/net-irc/smuxi/smuxi-0.9.ebuild
index 3c1d764..9e6ecd9 100644
--- a/net-irc/smuxi/smuxi-0.9.ebuild
+++ b/net-irc/smuxi/smuxi-0.9.ebuild
@@ -50,8 +50,9 @@ src_configure() {
$(use_with spell gtkspell)
}
-pkg_postinst() {
+src_install() {
+ default
#runner scripts fix
- sed -i -e 's@mono --debug@mono --runtime=v4.0@g' /usr/bin/smuxi-frontend-gnome || die
- sed -i -e 's@mono --debug@mono --runtime=v4.0@g' /usr/bin/smuxi-server || die
+ sed -i -e 's@mono --debug@mono --runtime=v4.0@g' "${ED}"/usr/bin/smuxi-frontend-gnome || die
+ sed -i -e 's@mono --debug@mono --runtime=v4.0@g' "${ED}"/usr/bin/smuxi-server || die
}
diff --git a/net-irc/smuxi/smuxi-9999.ebuild b/net-irc/smuxi/smuxi-9999.ebuild
index 462e69a..a8077d9 100644
--- a/net-irc/smuxi/smuxi-9999.ebuild
+++ b/net-irc/smuxi/smuxi-9999.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI="5"
-inherit eutils mono-env git-2
+inherit eutils mono-env git-2 autotools-utils
DESCRIPTION="A flexible, irssi-like and user-friendly IRC client for the Gnome Desktop"
HOMEPAGE="http://www.smuxi.org/main/"
@@ -17,7 +17,7 @@ RDEPEND="
>=dev-lang/mono-3.0
>=dev-dotnet/smartirc4net-0.4.5.1
>=dev-dotnet/nini-1.1.0-r2
- =dev-dotnet/log4net-1.2.10
+ >=dev-dotnet/log4net-1.2.10
dbus? ( dev-dotnet/ndesk-dbus
dev-dotnet/ndesk-dbus-glib )
gtk? ( >=dev-dotnet/gtk-sharp-2.12 )
@@ -37,28 +37,35 @@ else
EGIT_REPO_URI="git://github.com/meebey/smuxi.git"
EGIT_MASTER="master"
fi
+EGIT_HAS_SUBMODULES=1
DOCS=( FEATURES TODO README )
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ ./autogen.sh MCS=$(which dmcs) || die
+}
src_configure() {
- # Our dev-dotnet/db4o is completely unmaintained
- # We don't have ubuntu stuff
- econf \
- --enable-engine-irc \
- --without-indicate \
- --with-vendor-package-version="Gentoo ${PV}" \
- --with-db4o=included \
- --with-messaging-menu=no \
- --with-indicate=no \
- --disable-engine-jabbr \
- $(use_enable debug) \
- $(use_enable gtk frontend-gnome) \
- $(use_with libnotify notify) \
+ local myeconfargs=(
+ --enable-engine-irc
+ --without-indicate
+ --with-vendor-package-version="Gentoo"
+ --with-db4o=included
+ --with-messaging-menu=no
+ --with-indicate=no
+ --disable-engine-jabbr
+ $(use_enable debug)
+ $(use_enable gtk frontend-gnome)
+ $(use_with libnotify notify)
$(use_with spell gtkspell)
+ )
+ autotools-utils_src_configure
}
-pkg_postinst() {
+src_install() {
+ default
#runner scripts fix
- sed -i -e 's@mono --debug@mono --runtime=v4.0@g' /usr/bin/smuxi-frontend-gnome || die
- sed -i -e 's@mono --debug@mono --runtime=v4.0@g' /usr/bin/smuxi-server || die
+ sed -i -e 's@mono --debug@mono --runtime=v4.0@g' "${ED}"/usr/bin/smuxi-frontend-gnome || die
+ sed -i -e 's@mono --debug@mono --runtime=v4.0@g' "${ED}"/usr/bin/smuxi-server || die
}