aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-08-16 00:47:27 +0200
committerSebastian Pipping <sping@gentoo.org>2015-08-16 00:49:51 +0200
commitc84c44df784e235f8f1eb7ccc2444010e9f4827d (patch)
treed5f51516f87589738c415916581d88b3509c338e
parentdev-java/jsr250: Fix license (diff)
downloadeclipse-c84c44df784e235f8f1eb7ccc2444010e9f4827d.tar.gz
eclipse-c84c44df784e235f8f1eb7ccc2444010e9f4827d.tar.bz2
eclipse-c84c44df784e235f8f1eb7ccc2444010e9f4827d.zip
dev-util/eclipse-sdk-bin: 4.5.0
Based on prior work from the java overlay
-rw-r--r--dev-util/eclipse-sdk-bin/Manifest2
-rw-r--r--dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.0.ebuild84
-rw-r--r--dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipse-bin43
-rw-r--r--dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipserc-bin20
-rw-r--r--dev-util/eclipse-sdk-bin/metadata.xml8
5 files changed, 157 insertions, 0 deletions
diff --git a/dev-util/eclipse-sdk-bin/Manifest b/dev-util/eclipse-sdk-bin/Manifest
new file mode 100644
index 0000000..6564fa2
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/Manifest
@@ -0,0 +1,2 @@
+DIST eclipse-java-mars-R-linux-gtk-4.5.0.tar.gz 169974282 SHA256 43089aa4738d05e92fd24cf320336e8ab1cfd2e66ce07de9955a40bf7a08de87 SHA512 de17412b82c6150268142e99858f26641b465c1c296a1a13d413a47226dc9a01db26bd07985c926b5fe80e0225ff7b3e0ef35137fce31e0bb261ae5cc96cc888 WHIRLPOOL 9ccbcc5c36711531a2f93daf8bab92892f589822cee09f5751fcf0ab7a1fe3e183100cfe4a9e71ecefe3a04a1b2bae2843162b27250a052ed4846f343fa0bbb1
+DIST eclipse-java-mars-R-linux-gtk-x86_64-4.5.0.tar.gz 170118332 SHA256 2eeea5e563001f6812bad97e159befe4152bf8ef49124c98e635fd68104a1727 SHA512 9997a23d29e95c91177cd7460291caab46f04ca9b4af52b724c0d61577a16fa69b0aa4cdd01322aba21a05da24380d3f9395f799be4af8fc41c373353573a517 WHIRLPOOL 4d468c1959e2f9dd5b5fd661e60b56c55aa6d5fbc4b090d749237dfb56146213ab51716c8f645a288357b9302975d84a9aa502f94b07d78a7da31d84dead48db
diff --git a/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.0.ebuild b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.0.ebuild
new file mode 100644
index 0000000..e8053ad
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator java-utils-2
+
+SR="R"
+RNAME="mars"
+
+SRC_BASE="http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${RNAME}/${SR}/eclipse-java-${RNAME}-${SR}-linux-gtk"
+
+DESCRIPTION="Eclipse SDK"
+HOMEPAGE="http://www.eclipse.org"
+SRC_URI="
+ amd64? ( ${SRC_BASE}-x86_64.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-x86_64-${PV}.tar.gz )
+ x86? ( ${SRC_BASE}.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-${PV}.tar.gz )
+ "
+
+LICENSE="EPL-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-java/icu4j-54.1.1:52
+ >=dev-java/jsr250-1.2:0
+ "
+DEPEND="${CDEPEND}"
+RDEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}"/eclipse
+
+_unbundle_single() {
+ local mode="${1}" destination_jar="${2}" package="${3}" package_jar="${4}"
+ if [[ "${mode}" = delete ]]; then
+ rm "${destination_jar}" || die
+ elif [[ "${mode}" = wire ]]; then
+ java-pkg_jar-from "${package}" "${package_jar}" "${destination_jar}"
+ fi
+}
+
+_unbundle_known() {
+ local mode="${1}"
+
+ ewarn 'Unbundling broken, skipping.'
+ return 0
+
+ # https://wiki.gentoo.org/wiki/Eclipse/Building_From_Source
+ _unbundle_single "${mode}" plugins/com.ibm.icu_54.1.1.v201501272100.jar icu4j-52 icu4j.jar log4j-1.2.8.jar
+ _unbundle_single "${mode}" plugins/javax.annotation_1.2.0.v201401042248.jar jsr250 jsr250.jar
+}
+
+src_prepare() {
+ _unbundle_known delete
+
+ ewarn 'Binary dependencies left to unbundle:'
+ ewarn "$(find -type f -name '*.jar' -not -wholename '*/org.eclipse*' | sort | sed 's,^\./,,')"
+
+ _unbundle_known wire
+
+ cp "${FILESDIR}"/${P}-eclipse-bin "${T}/eclipse-bin-${SLOT}" || die
+ cp "${FILESDIR}"/${P}-eclipserc-bin "${T}/eclipserc-bin-${SLOT}" || die
+ sed "s,%SLOT%,${SLOT},g" -i "${T}"/eclipse{,rc}-bin-${SLOT} || die
+}
+
+src_install() {
+ local dest=/opt/${PN}-${SLOT}
+
+ insinto ${dest}
+ doins -r features icon.xpm plugins artifacts.xml p2 eclipse.ini configuration dropins
+
+ exeinto ${dest}
+ doexe eclipse
+
+ dohtml -r readme/*
+
+ dobin "${T}"/eclipse-bin-${SLOT}
+ insinto /etc
+ doins "${T}"/eclipserc-bin-${SLOT}
+ make_desktop_entry "eclipse-bin-${SLOT}" "Eclipse ${RNAME^}/${PV} (bin)" "${dest}/icon.xpm"
+}
diff --git a/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipse-bin b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipse-bin
new file mode 100644
index 0000000..87d5531
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipse-bin
@@ -0,0 +1,43 @@
+#! /bin/bash
+#
+# Tiny startup wrapper for Eclipse
+#
+# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright (c) 2007-2008, Jean-Noël Rivasseau <elvanor@gentoo.org>
+# Copyright (c) 2004-2008, Gentoo Foundation
+# Copyright (c) 2015, Sebastian Pipping <sping@gentoo.org>
+#
+# Licensed under the GNU General Public License, version 2
+#
+
+[[ -f "/etc/eclipserc-bin-%SLOT%" ]] && . "/etc/eclipserc-bin-%SLOT%"
+[[ -f "$HOME/gentoo/.eclipserc" ]] && . "$HOME/gentoo/.eclipserc"
+
+ECLIPSE_HOME=${ECLIPSE_HOME:="/opt/eclipse-sdk-bin-%SLOT%"}
+ECLIPSE_BIN="${ECLIPSE_HOME}/eclipse"
+
+if [[ ! -x "${ECLIPSE_BIN}" ]] ; then
+ echo "Failed to find executable '${ECLIPSE_BIN}'" > /dev/stderr
+ exit 1
+fi
+
+if [[ $(id -u) -eq 0 ]] ; then
+ echo "Do not run eclipse as root user! Exiting ..." > /dev/stderr
+ exit 1
+fi
+
+case "$(java-config -f)" in
+ *gcj*)
+ export JAVA_PKG_CLASSMAP="${ECLIPSE_HOME}/eclipse.gcjdb"
+ ;;
+esac
+
+[ -n "${ECLIPSE_XMS}" ] && VM_ARGS="${VM_ARGS} -Xms${ECLIPSE_XMS}"
+[ -n "${ECLIPSE_XMX}" ] && VM_ARGS="${VM_ARGS} -Xmx${ECLIPSE_XMX}"
+[ -n "${ECLIPSE_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:PermSize=${ECLIPSE_PERMSIZE}"
+[ -n "${ECLIPSE_MAX_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:MaxPermSize=${ECLIPSE_MAX_PERMSIZE}"
+
+# Fix for JRE 1.5.
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib
+
+exec "${ECLIPSE_BIN}" -vm $(java-config --java) "$@" "${ECLIPSE_USER_ARGS}" -vmargs ${VM_ARGS}
diff --git a/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipserc-bin b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipserc-bin
new file mode 100644
index 0000000..c2c334e
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.0-eclipserc-bin
@@ -0,0 +1,20 @@
+# This file specifies some initial Eclipse settings, like memory allowed
+# These settings only affect Eclipse startup and overall configuration
+# Main Eclipse configuration should be done within Eclipse (with the GUI)
+
+# Following variables controls the minimal and maximum amounts of memory
+# allocated to Eclipse (respectively).
+# Increase those numbers if you get OutOfMemory errors.
+
+ECLIPSE_XMS=128m
+ECLIPSE_XMX=256m
+
+# Following variables controls the minimal and maximum amounts of memory
+# allocated to the permanent generation space.
+# This space contains data related to all classes.
+# Thus, if you use a lot of Eclipse plugins, it is recommended to uncomment
+# these variables and even increase it, if you have enough RAM.
+# Else you will get crashes related to OutOfMemory in PermGen exceptions.
+
+#ECLIPSE_PERMSIZE=64m
+#ECLIPSE_MAX_PERMSIZE=128m
diff --git a/dev-util/eclipse-sdk-bin/metadata.xml b/dev-util/eclipse-sdk-bin/metadata.xml
new file mode 100644
index 0000000..16bcc9f
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>