aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-03-14 12:01:49 +0100
committerDavid Roman <davidroman96@gmail.com>2024-03-14 12:02:34 +0100
commitd7682d7c63435c6b3b36ac6a10a3d3e8723ce37e (patch)
tree5d7f70169c0b791b888bc7d739399155a57bb015 /app-admin
parentgui-apps/wlr-randr: drop 0.3.0 (diff)
downloadguru-d7682d7c63435c6b3b36ac6a10a3d3e8723ce37e.tar.gz
guru-d7682d7c63435c6b3b36ac6a10a3d3e8723ce37e.tar.bz2
guru-d7682d7c63435c6b3b36ac6a10a3d3e8723ce37e.zip
app-admin/pass-audit: fix wrong installed files
Closes: https://bugs.gentoo.org/921706 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pass-audit/pass-audit-1.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/pass-audit/pass-audit-1.2-r1.ebuild b/app-admin/pass-audit/pass-audit-1.2-r1.ebuild
new file mode 100644
index 000000000..1e263f07f
--- /dev/null
+++ b/app-admin/pass-audit/pass-audit-1.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10,11,12} )
+
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="A pass extension for auditing your password repository. "
+HOMEPAGE="https://github.com/roddhjav/pass-audit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests seems broken
+RESTRICT="test"
+
+DEPEND="app-admin/pass"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Wrokaround for #921706
+ echo -e "from setuptools import setup\nsetup()" > setup.py || die
+
+ default
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp share/bash-completion/completions/pass-audit "${PN}"
+ newzshcomp share/zsh/site-functions/_pass-audit _"${PN}"
+ doman share/man/man1/pass-audit.1
+
+ exeinto /usr/lib/password-store/extensions
+ doexe audit.bash
+}