aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-02-18 14:02:31 -0500
committerJulien Roy <julien@jroy.ca>2024-02-18 14:02:31 -0500
commit849ec8f7d6ccfbf42640f4b47a69103b0eb0f323 (patch)
treeb72e40b35aa972fd5cf824dfeaaf047358527c54 /app-containers/waydroid
parentdev-python/http-ece: disable py3.12 (diff)
downloadguru-849ec8f7d6ccfbf42640f4b47a69103b0eb0f323.tar.gz
guru-849ec8f7d6ccfbf42640f4b47a69103b0eb0f323.tar.bz2
guru-849ec8f7d6ccfbf42640f4b47a69103b0eb0f323.zip
app-containers/waydroid: add 1.4.2
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'app-containers/waydroid')
-rw-r--r--app-containers/waydroid/Manifest1
-rw-r--r--app-containers/waydroid/waydroid-1.4.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-containers/waydroid/Manifest b/app-containers/waydroid/Manifest
index 249078cee4..59ad458dab 100644
--- a/app-containers/waydroid/Manifest
+++ b/app-containers/waydroid/Manifest
@@ -1 +1,2 @@
DIST waydroid-1.4.0.tar.gz 237562 BLAKE2B 28f711bf0fe8b5254739d1a6769f466bcc593f3c61df1bef9e2a3fab80a97fe44b9509907c100e3178e343fd264955894b38ee1be5b6ce0c6ea5d473b6958a7f SHA512 2f1e4c112dbe68ad15d69441a37ba631d148c95810f0ca1e6e1c45461089d5f5e0990a58c2324449b69199b6b24d32c110063c4dfaf89b537779915ec3f3b69d
+DIST waydroid-1.4.2.tar.gz 242536 BLAKE2B 77a6ba3a00bc2c95f767bec9ec93d1e4dcd3e20cf39d8c3ce0dea00f6c1c2a1eb6399f2ef0d8017958584205d067646d0e50d0f865c954284b7384f4a492a084 SHA512 0d3eba799895c853545b7087e3c07160d593d4a3166822039973669bc0ee93a8a6b9c394a7d982e57cfbbfbd8df1ba7991dd33b1b1517d79fcbe191d8a86890a
diff --git a/app-containers/waydroid/waydroid-1.4.2.ebuild b/app-containers/waydroid/waydroid-1.4.2.ebuild
new file mode 100644
index 0000000000..25f3025a5d
--- /dev/null
+++ b/app-containers/waydroid/waydroid-1.4.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit linux-info xdg-utils python-single-r1
+
+DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
+HOMEPAGE="https://waydro.id"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="systemd apparmor"
+
+DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )"
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ app-containers/lxc[systemd?,apparmor?,seccomp]
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/gbinder-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyclip-0.7.0[wayland,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ net-firewall/nftables
+ net-dns/dnsmasq
+ >=dev-libs/libglibutil-1.0.67
+ >=dev-libs/gbinder-1.1.21
+ ${PYTHON_DEPS}
+"
+
+CONFIG_CHECK="
+ ~ANDROID_BINDER_IPC
+ ~ANDROID_BINDERFS
+ ~MEMFD_CREATE
+"
+ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
+ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
+ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers,
+ therefore it's vital for android-specific memory management"
+
+src_compile(){
+ :;
+}
+
+src_install() {
+ python_fix_shebang waydroid.py
+ emake install DESTDIR="${D}" USE_NFTABLES=1 USE_SYSTEMD=$(usex systemd 1 0)
+ if ! use systemd; then
+ elog "Installing waydroid OpenRC daemon"
+ doinitd "${FILESDIR}"/waydroid
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if ! use apparmor; then
+ ewarn "If you use app-containers/lxc without apparmor, make sure you deleted or commented out in waydroid LXC config"
+ ewarn "(generated after waydroid init) in /var/lib/waydroid/lxc/waydroid/config the following string:"
+ ewarn "lxc.apparmor.profile = unconfined"
+ ewarn "or waydroid experiences crash during launch"
+ ewarn "See also https://github.com/waydroid/waydroid/issues/652"
+ else
+ ewarn "Apparmor support has not been tested by package maintainer yet"
+ fi
+ ewarn "Make sure you have NFTABLES up and running in your kernel. See"
+ ewarn "https://wiki.gentoo.org/wiki/Nftables for how-to details"
+ einfo "After package installation run ether 'emerge --config app-containers/waydroid'"
+ einfo "or 'waydroid init' from root shell to install android container runtime"
+ einfo "To run waydroid, 1. Start container: 'rc-service waydroid start'"
+ einfo "2. start wayland channel (from user shell) 'waydroid session start'"
+ einfo "Contact https://docs.waydro.id/usage/install-on-desktops for how-to guides"
+ einfo "(does not cover Gentoo-specific things sadly)"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_config() {
+ "${ROOT}"/usr/bin/waydroid init
+}