aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2024-03-21 19:22:56 +0100
committerEsteve Varela Colominas <esteve.varela@gmail.com>2024-03-21 23:10:44 +0100
commitf235c2515d3f4305d97f39de4cc0794057f02546 (patch)
tree6fc766e5b75f23767d60cff7dd6aa25f8bce056b /app-containers/waydroid
parentapp-containers/waydroid: Make important messages more visible (diff)
downloadguru-f235c2515d3f4305d97f39de4cc0794057f02546.tar.gz
guru-f235c2515d3f4305d97f39de4cc0794057f02546.tar.bz2
guru-f235c2515d3f4305d97f39de4cc0794057f02546.zip
app-containers/waydroid: Minor improvements
Use xdg.eclass instead of calling the functions individually, support Gentoo Prefix by using EROOT. Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com>
Diffstat (limited to 'app-containers/waydroid')
-rw-r--r--app-containers/waydroid/waydroid-1.4.0.ebuild12
-rw-r--r--app-containers/waydroid/waydroid-1.4.2.ebuild12
2 files changed, 6 insertions, 18 deletions
diff --git a/app-containers/waydroid/waydroid-1.4.0.ebuild b/app-containers/waydroid/waydroid-1.4.0.ebuild
index 17e3547703..64f69da5d3 100644
--- a/app-containers/waydroid/waydroid-1.4.0.ebuild
+++ b/app-containers/waydroid/waydroid-1.4.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit linux-info xdg-utils python-single-r1
+inherit linux-info xdg python-single-r1
DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
HOMEPAGE="https://waydro.id"
@@ -57,8 +57,7 @@ src_install() {
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
elog "After package installation run either 'emerge --config app-containers/waydroid'"
elog "or 'waydroid init' from root shell to install android container runtime"
@@ -83,11 +82,6 @@ pkg_postinst() {
fi
}
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
pkg_config() {
- "${ROOT}"/usr/bin/waydroid init
+ "${EROOT}"/usr/bin/waydroid init
}
diff --git a/app-containers/waydroid/waydroid-1.4.2.ebuild b/app-containers/waydroid/waydroid-1.4.2.ebuild
index 5d5b8a91f8..10bd38daf4 100644
--- a/app-containers/waydroid/waydroid-1.4.2.ebuild
+++ b/app-containers/waydroid/waydroid-1.4.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit linux-info xdg-utils python-single-r1
+inherit linux-info xdg python-single-r1
DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
HOMEPAGE="https://waydro.id"
@@ -57,8 +57,7 @@ src_install() {
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
elog "After package installation run either 'emerge --config app-containers/waydroid'"
elog "or 'waydroid init' from root shell to install android container runtime"
@@ -83,11 +82,6 @@ pkg_postinst() {
fi
}
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
pkg_config() {
- "${ROOT}"/usr/bin/waydroid init
+ "${EROOT}"/usr/bin/waydroid init
}