aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-05-08 03:30:21 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-05-08 03:31:20 +0200
commitb462f0d57c3f184aab74fd154db6e24ea8c69d8c (patch)
tree500f9beb4f3aa27ec7850d351b276ae7bc9a26dd /app-crypt
parentapp-crypt/sac-core: update LICENSE (diff)
downloadguru-b462f0d57c3f184aab74fd154db6e24ea8c69d8c.tar.gz
guru-b462f0d57c3f184aab74fd154db6e24ea8c69d8c.tar.bz2
guru-b462f0d57c3f184aab74fd154db6e24ea8c69d8c.zip
app-crypt/sac-core: use unpacker eclass for deb archive
Add missing unzip build-time dependency Fix variable order Closes: https://bugs.gentoo.org/931337 Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/sac-core/sac-core-10.8.1050-r1.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/app-crypt/sac-core/sac-core-10.8.1050-r1.ebuild b/app-crypt/sac-core/sac-core-10.8.1050-r1.ebuild
index 5d3627cdc..26f76629e 100644
--- a/app-crypt/sac-core/sac-core-10.8.1050-r1.ebuild
+++ b/app-crypt/sac-core/sac-core-10.8.1050-r1.ebuild
@@ -3,11 +3,14 @@
EAPI=8
-DESCRIPTION="Thales/Gemalto SafeNet Authentication Client for eToken 5110/5300 & IDPrime (core PKCS#11 modules)"
+inherit systemd unpacker
+DESCRIPTION="Thales/Gemalto SafeNet Authentication Client for eToken 5110/5300 & IDPrime (core PKCS#11 modules)"
+HOMEPAGE="https://cpl.thalesgroup.com/access-management/security-applications/authentication-client-token-management"
SRC_URI="https://nullroute.lt/tmp/2023/pkg/SAC_Linux_10.8.105_R1_GA.zip"
-HOMEPAGE="https://cpl.thalesgroup.com/access-management/security-applications/authentication-client-token-management"
+S="${WORKDIR}"
+
LICENSE="sac-core-10.8.1050-terms LGPL-2.1 ZLIB"
SLOT="0"
KEYWORDS="~amd64"
@@ -16,8 +19,6 @@ IUSE="+ssl"
# binaries are already stripped
RESTRICT="bindist mirror strip"
-inherit systemd
-
RDEPEND="
dev-libs/openssl
sys-apps/pcsc-lite
@@ -26,16 +27,11 @@ RDEPEND="
ssl? ( dev-libs/libp11 )
"
DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_unpack() {
default
-
- cd "$S" || die
-
- unpack "SAC Linux ${PV} R1 GA/Installation/withoutUI/Ubuntu-2204/safenetauthenticationclient-core_${PV}_amd64.deb" || die
- unpack "./data.tar.gz" || die
+ unpacker "SAC Linux ${PV} R1 GA/Installation/withoutUI/Ubuntu-2204/safenetauthenticationclient-core_${PV}_amd64.deb"
}
src_install() {