aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-09-06 11:35:56 +0800
committerHuang Rui <vowstar@gmail.com>2022-09-06 11:35:56 +0800
commite07c00ad7689bb8a7fc1e673f68468e2a75c681f (patch)
tree99a79a3bc964013ecfb5371cf5974dd98523db9c /app-editors
parentsys-process/nvtop: drop 2.0.2 (diff)
downloadguru-e07c00ad7689bb8a7fc1e673f68468e2a75c681f.tar.gz
guru-e07c00ad7689bb8a7fc1e673f68468e2a75c681f.tar.bz2
guru-e07c00ad7689bb8a7fc1e673f68468e2a75c681f.zip
app-editors/imhex: add 1.22.0
Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/imhex/Manifest2
-rw-r--r--app-editors/imhex/imhex-1.22.0.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/app-editors/imhex/Manifest b/app-editors/imhex/Manifest
index fa985686e..40d82ba74 100644
--- a/app-editors/imhex/Manifest
+++ b/app-editors/imhex/Manifest
@@ -1,2 +1,4 @@
DIST imhex-1.21.2.tar.gz 23473112 BLAKE2B 5e1dbcf246fc2b2ac57636efee71574eb38ee2d04678a6e09b4d8c2d61da01021bb169fa40a18725d609a3daae1bf9a4ca8aacbb21b6d381c3ff1345d9f788c6 SHA512 e5dd9c5b81f739ee37cc51cf37aa6b866b1af8b28f06e0731612612c5a56d5d68d9d50c20ebb9304a51efb88c07fde72656dcc7d6c249dd827d5d15e44de9698
+DIST imhex-1.22.0.tar.gz 23801722 BLAKE2B db82e9fb74244cc591da60f6b3ae7d66db2907a216f5246973c5c3012e713c01d426fcf2d87ddb6ac92a0cff8f2a89119341f2f806bcce59d117c6a15ca58038 SHA512 e29015b8850c76f43f42920b1ee93af72cbd28a12a1e555177f580270da6f71391f638cadb34333fa3a7db8f3fe15acb666b5d8b67acde9dcbe5c468e2e6b06f
DIST imhex-patterns-1.21.2.tar.gz 4672663 BLAKE2B a0c4a9917ad44a4af0e01e67210bb025a01e6775b327248ba9259d36ea0596b2be74aed758d478b3f5c0d0aea669ed333c8aca2b7e43e275abc833bbdcef2490 SHA512 c5694bd5cc6a609dd8133f0566fbf3bfd4669cf4a20523d10afddbc39e4b7a8d52d8fdecff95883e40b6f06f858e1373c8dbe0713fd7f54380dac5ee3105b9ce
+DIST imhex-patterns-1.22.0.tar.gz 4749715 BLAKE2B ae157b664f7a0e163d915c21ca34d5e207ee5a51896db2e8370a66574d68375eb6d31f872dd20f8ba592f2270a7615f921e840f6ffb2a6ee4253e30689245b60 SHA512 2ce01986993283a254e59d44eb3948180cb4038f2b0b3fb1aa93154509500c8eb7315cf7b5aa3ee1887456936dd68c3fc8bac52f2a0c90a3b0567a4f0253dede
diff --git a/app-editors/imhex/imhex-1.22.0.ebuild b/app-editors/imhex/imhex-1.22.0.ebuild
new file mode 100644
index 000000000..09fd29f32
--- /dev/null
+++ b/app-editors/imhex/imhex-1.22.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake desktop llvm python-r1 xdg
+
+DESCRIPTION="A hex editor for reverse engineers, programmers, and eyesight"
+HOMEPAGE="https://github.com/WerWolv/ImHex"
+SRC_URI="
+ https://github.com/WerWolv/ImHex/releases/download/v${PV}/Full.Sources.tar.gz -> ${P}.tar.gz
+ https://github.com/WerWolv/ImHex-Patterns/archive/refs/tags/ImHex-v${PV}.tar.gz -> ${PN}-patterns-${PV}.tar.gz
+"
+S="${WORKDIR}/ImHex"
+S_PATTERNS="${WORKDIR}/ImHex-Patterns-ImHex-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+ app-forensics/yara
+ dev-libs/capstone
+ >=dev-libs/libfmt-8.0.0
+ dev-libs/openssl
+ dev-libs/tre
+ media-libs/freetype
+ media-libs/glfw
+ media-libs/glm
+ net-libs/libssh2
+ net-libs/mbedtls
+ net-misc/curl
+ sys-apps/dbus
+ sys-apps/file
+ sys-apps/xdg-desktop-portal
+ virtual/libiconv
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-admin/chrpath
+ >=dev-cpp/nlohmann_json-3.10.2
+ gnome-base/librsvg
+ sys-devel/llvm
+"
+
+src_configure() {
+ use python && python_setup
+
+ local mycmakeargs=(
+ -D CMAKE_SKIP_RPATH=ON \
+ -D IMHEX_IGNORE_BAD_CLONE=ON \
+ -D IMHEX_OFFLINE_BUILD=ON \
+ -D IMHEX_STRIP_RELEASE=OFF \
+ -D IMHEX_VERSION="${PV}" \
+ -D PROJECT_VERSION="${PV}" \
+ -D USE_SYSTEM_CAPSTONE=ON \
+ -D USE_SYSTEM_CURL=ON \
+ -D USE_SYSTEM_FMT=ON \
+ -D USE_SYSTEM_LLVM=ON \
+ -D USE_SYSTEM_NLOHMANN_JSON=ON \
+ -D USE_SYSTEM_YARA=ON
+ )
+ if use python; then
+ mycmakeargs+=( -D PYTHON_VERSION_MAJOR_MINOR="\"${EPYTHON/python/}\"" )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ # Can't use cmake_src_install, doing it manual
+ # Executable
+ dobin "${BUILD_DIR}/${PN}"
+ chrpath -d "${ED}/usr/bin/${PN}"
+ # Shared lib and plugins
+ dolib.so "${BUILD_DIR}"/lib/lib"${PN}"/lib"${PN}".so*
+ chrpath -d "${ED}"/usr/bin/lib"${PN}"/lib"${PN}".so*
+ exeinto "/usr/$(get_libdir)/${PN}/plugins"
+ for plugin in builtin; do
+ doexe "${BUILD_DIR}/plugins/${plugin}.hexplug"
+ chrpath -d "${ED}/usr/$(get_libdir)/${PN}/plugins/${plugin}.hexplug"
+ done
+ # Desktop and icon files
+ domenu "${S}/dist/${PN}.desktop"
+ newicon -s scalable "${S}/resources/icon.svg" "${PN}.svg"
+ for i in 16 22 24 32 36 48 64 72 96 128 192 256 512; do
+ mkdir "${T}/${i}x${i}" || die
+ rsvg-convert -a -f png -w "${i}" -o "${T}/${i}x${i}/${PN}.png" "${S}/resources/icon.svg" || die
+ doicon -s "${i}" "${T}/${i}x${i}/${PN}.png"
+ done
+
+ if use python; then
+ installation() {
+ mypythondir="${D}/$(python_get_sitedir)/${PN}"
+ mkdir -p "${mypythondir}" || die
+ cp -r "${S}"/resources/lib/python/lib/* "${mypythondir}" || die
+ python_optimize "${mypythondir}"
+ }
+ python_foreach_impl installation
+ fi
+
+ # Install docs
+ einstalldocs
+
+ # Install patterns
+ insinto /usr/share/imhex
+ doins -r "${S_PATTERNS}"/*
+}