aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-06-20 17:54:38 +0100
committerMatt Smith <matt@offtopica.uk>2021-06-20 17:54:38 +0100
commit3937855cf1fad9045782b3e8d3f1fcf8ec948508 (patch)
tree92ce1a9b0b1374b18ab6d28d22c26cd6e531d3b0 /app-emacs
parentgames-engines/instead: remove trailing whitespace (diff)
downloadguru-3937855cf1fad9045782b3e8d3f1fcf8ec948508.tar.gz
guru-3937855cf1fad9045782b3e8d3f1fcf8ec948508.tar.bz2
guru-3937855cf1fad9045782b3e8d3f1fcf8ec948508.zip
app-emacs/prop-menu: Fix tests
Closes: https://bugs.gentoo.org/796968 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/prop-menu/prop-menu-0.1.2.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-emacs/prop-menu/prop-menu-0.1.2.ebuild b/app-emacs/prop-menu/prop-menu-0.1.2.ebuild
index 005e99afa..d1e7ebca2 100644
--- a/app-emacs/prop-menu/prop-menu-0.1.2.ebuild
+++ b/app-emacs/prop-menu/prop-menu-0.1.2.ebuild
@@ -16,3 +16,19 @@ KEYWORDS="~amd64"
S="${WORKDIR}/prop-menu-el-${PV}"
SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l ert -l prop-menu-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} prop-menu.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+}