aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-21 22:27:01 +1300
committerTheo Anderson <telans@posteo.de>2020-12-21 22:27:01 +1300
commit87945f7bbb4dd6ca786a7bd62607a38129179930 (patch)
treee9b2dda5cb3603da1e79abd5e2b6532c060a42d7 /app-misc/mat2
parentx11-misc/ksnip: bump to 1.8.0 (diff)
downloadguru-87945f7bbb4dd6ca786a7bd62607a38129179930.tar.gz
guru-87945f7bbb4dd6ca786a7bd62607a38129179930.tar.bz2
guru-87945f7bbb4dd6ca786a7bd62607a38129179930.zip
app-misc/mat2: bump to 0.12.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'app-misc/mat2')
-rw-r--r--app-misc/mat2/Manifest1
-rw-r--r--app-misc/mat2/mat2-0.12.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/mat2/Manifest b/app-misc/mat2/Manifest
index 29cad018e..03e2b8da5 100644
--- a/app-misc/mat2/Manifest
+++ b/app-misc/mat2/Manifest
@@ -1 +1,2 @@
DIST mat2-0.11.0.tar.gz 10151787 BLAKE2B c55d04fe7d49e8515bc5bc3ebfad4c71ddec670e5efed9855545bc32374661bb92501fb5910a599f27d97a3089a44f983c983cb82572ab153602d38e39682164 SHA512 8396a32b409b83cc4158546f92d458bc8a62e5aabd2c452402ac6185c2efdeff8794a7e1e45a8e39e9eaba31e256a303ca0be38b65fd43f11e7b07d1ea8b2f06
+DIST mat2-0.12.0.tar.gz 10153108 BLAKE2B 961fb4ee55258b6c727f4f143ba87a8a898fb41fff9a99a2a548ed493a3d8e635c0e347fadfacd6cca4a44db46d22ea5b9c5461eed447a897b04b7fc1d79d802 SHA512 de1969534029a81f2a341ec52fc9db007f687fdd7f20c46328348ca1b5b18a75763795daf1141532f0c11d5e4574a705aa389cbb6b50ebbbe5ab8ebb348a69ba
diff --git a/app-misc/mat2/mat2-0.12.0.ebuild b/app-misc/mat2/mat2-0.12.0.ebuild
new file mode 100644
index 000000000..4d354b47c
--- /dev/null
+++ b/app-misc/mat2/mat2-0.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Metadata Anonymisation Toolkit: handy tool to trash your metadata"
+HOMEPAGE="https://0xacab.org/jvoisin/mat2"
+SRC_URI="https://0xacab.org/jvoisin/mat2/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+exif sandbox video"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( exif video )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/poppler[introspection]
+ dev-python/pycairo:0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2[introspection]
+ media-libs/mutagen:0[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ exif? ( media-libs/exiftool:* )
+ sandbox? ( sys-apps/bubblewrap )
+ video? ( media-video/ffmpeg:* )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ media-video/ffmpeg[mp3,vorbis]
+ x11-libs/gdk-pixbuf:2[jpeg,tiff]
+ )
+"
+
+distutils_enable_tests unittest