aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-11 23:50:02 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-11 23:59:10 +0100
commit5c308ceaa0e861cd078957b63ba1685bb0c0925e (patch)
treec63e5d69d4e23e4632fc1ccc56a76982b94928f5 /app-shells
parentdev-util/yaml-language-server: add 1.11.0 (diff)
downloadguru-5c308ceaa0e861cd078957b63ba1685bb0c0925e.tar.gz
guru-5c308ceaa0e861cd078957b63ba1685bb0c0925e.tar.bz2
guru-5c308ceaa0e861cd078957b63ba1685bb0c0925e.zip
app-shells/zsh-async: add 1.8.6
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-async/Manifest1
-rw-r--r--app-shells/zsh-async/zsh-async-1.8.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/zsh-async/Manifest b/app-shells/zsh-async/Manifest
index f0b058ecd..0fe277056 100644
--- a/app-shells/zsh-async/Manifest
+++ b/app-shells/zsh-async/Manifest
@@ -1,2 +1,3 @@
DIST zsh-async-1.8.5.tar.gz 18346 BLAKE2B 9ac98ca71caa569ca5ede093f9a4c690ac2aa4266b8a0b4ded9304ee241269ca7d3a3c6eb7e0aaa55a0da372725f65d66eb627fe7cae0c9c59f09c867d498038 SHA512 ad9139330c57cbfb115c0ee58763db19578279e9834593f06ab97857fd416bd40a0be3215e35b5d58e212f58f46359fe3b6c2caf9820cf946efeb541cccb7d0c
DIST zsh-async-1.8.5_p20211005.tar.gz 18508 BLAKE2B 25fe3dc647679571e7baeef4f92138062b9d658bc45aec8110736a1b186a7fe07d54660159bd85cb6c89ec793457ea453a833b656fb406d768c7f25329d085c7 SHA512 8a65a150772aa3e0b6ba1308affc2e008705430d46825803d029c8f4bee6eda7ee657239b3cfe7b87ba829aba929e8921912aa405f9707a9ae623e7b1e17fbff
+DIST zsh-async-1.8.6.tar.gz 18507 BLAKE2B 4fb49b941e260057a089b9fd0fc3f8b9b7d0e2f9765bf1ae9ba2d7b8ac7a82b7e873bb166dc17f58d2db858fda1efefc5b4ba76f6d735c1dcb901723c2334e95 SHA512 953632905851465c760f3bb2921fdfd7a886ab477ee846d799c82c8e0179e29c1fc1d6589305c7f1c4f9f20fe7d8250f66c92de02309f49f40f7ec71d5efc95d
diff --git a/app-shells/zsh-async/zsh-async-1.8.6.ebuild b/app-shells/zsh-async/zsh-async-1.8.6.ebuild
new file mode 100644
index 000000000..6b00fa4d7
--- /dev/null
+++ b/app-shells/zsh-async/zsh-async-1.8.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Run multiple asynchronous jobs with callbacks"
+HOMEPAGE="https://github.com/mafredri/zsh-async"
+SRC_URI="https://github.com/mafredri/zsh-async/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-shells/zsh"
+BDEPEND="
+ test? (
+ app-shells/zsh
+ dev-vcs/git
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/async.zsh
+at the end of your ~/.zshrc"
+
+src_test() {
+ git init || die "git repository initialization for testing failed"
+ ./test.zsh -v || die "One or more tests failed"
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins async.zsh
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}