aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2022-02-22 18:25:32 -0300
committerCarlos Eduardo <carana2099@gmail.com>2022-02-22 18:25:32 -0300
commit685a9bc05472da434eb121ddd9ff4941c2322499 (patch)
treeb77ad28d982576df8b77eb73c27aa48d2f355209 /app-text
parentapp-misc/neo: fix dangling symlink (diff)
downloadguru-685a9bc05472da434eb121ddd9ff4941c2322499.tar.gz
guru-685a9bc05472da434eb121ddd9ff4941c2322499.tar.bz2
guru-685a9bc05472da434eb121ddd9ff4941c2322499.zip
app-text/OCRmyPDF: add 13.4.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/OCRmyPDF/Manifest1
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-13.4.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-text/OCRmyPDF/Manifest b/app-text/OCRmyPDF/Manifest
index 8680e73f5..829604781 100644
--- a/app-text/OCRmyPDF/Manifest
+++ b/app-text/OCRmyPDF/Manifest
@@ -1,3 +1,4 @@
DIST OCRmyPDF-12.0.2.tar.gz 7895055 BLAKE2B 4fab449f9edf8788c74773da0e73adca9dc686afcbc69d9d6263049044b202744244eab4f4d6e5596461c55d399320a5e7604c6a8080c0d6a05ea6df15314eac SHA512 8bc749353d88dd1e0b2fbd313ba45fa5bf79b70c0366bde21dbe457ce269d02bea64e797e73b823fe9c02b2bd18f181f6cea414306ab1470e244e4201f86781a
DIST OCRmyPDF-12.6.0.tar.gz 7897200 BLAKE2B e183280e11414a7b2bedd339e971f1c74697d9847771e24592207e5bfe82af184544576c067856cdee9d8409bdca856e8aeb48c8e5b4e32154b69111fba2d775 SHA512 0792fccec7ecdfc93a02c4e29d0c88076c191aed3a2848c4db5d6b18ad4837a24e325dfc961aaa7c68407de7dd471e45e7b6389d6cf8f9465fe3892038696e97
DIST OCRmyPDF-13.2.0.tar.gz 7885396 BLAKE2B 0eea864d056d2238f7ea244a7fc9b6a548409caf9264349be2e0d5be5dea7ddc474f5e95ce92ad926992e42b27cdedf77005d124782374be5b6606a01338aa69 SHA512 476924ad440042fb75a9cd56fb90a93b636fc805393087952d704602f92bd0d33ed5701b45ed037b312874800857da784b367eaea3858dc0b38e4b1d49417e52
+DIST OCRmyPDF-13.4.0.tar.gz 7889193 BLAKE2B 42923508524df38ed62f1a0c4d6b308dac8e00a44b428dee2dd5494915778910e434d5bf8a5957fe48685c0263b3151044794b14cbc209e4a3909da1e2411fe3 SHA512 1b581ba469e0f625481c551d9b53c553745a02c748bd2e16bd7a589f4eacfd3f21ba5d435b52286694220627de0d3d7202513191ee5e1e04b7bdd392d0abc5cd
diff --git a/app-text/OCRmyPDF/OCRmyPDF-13.4.0.ebuild b/app-text/OCRmyPDF/OCRmyPDF-13.4.0.ebuild
new file mode 100644
index 000000000..ec16fef12
--- /dev/null
+++ b/app-text/OCRmyPDF/OCRmyPDF-13.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
+HOMEPAGE="https://github.com/jbarlow83/OCRmyPDF"
+SRC_URI="https://github.com/jbarlow83/OCRmyPDF/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# This uses *a lot* of RAM, I have 32gb and these tests tried to use it all
+RESTRICT="test"
+IUSE="jbig2enc"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/tesseract
+ app-text/unpaper
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ >=dev-python/pdfminer-six-20191110[${PYTHON_USEDEP}]
+ <=dev-python/pdfminer-six-20201018[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ media-gfx/img2pdf[${PYTHON_USEDEP}]
+ media-gfx/pngquant
+ media-libs/leptonica
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ jbig2enc? ( media-libs/jbig2enc )
+"
+DEPEND="
+ test? (
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp misc/completion/ocrmypdf.bash "${PN,,}"
+ insinto /usr/share/fish/vendor_completions.d
+ doins misc/completion/ocrmypdf.fish
+}