aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-12-21 10:12:16 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-12-21 10:14:09 +0100
commit28685f5a16361bca44edb81f5f9e93ae81b6e1f5 (patch)
treee45a314681500555fb0235aa10a49933e51d65af /dev-cpp
parentdev-cpp/qt-jdenticon: drop 0.2.1 (diff)
downloadguru-28685f5a16361bca44edb81f5f9e93ae81b6e1f5.tar.gz
guru-28685f5a16361bca44edb81f5f9e93ae81b6e1f5.tar.bz2
guru-28685f5a16361bca44edb81f5f9e93ae81b6e1f5.zip
dev-cpp/trantor: remove -Werror
Closes: https://bugs.gentoo.org/887325 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/trantor-1.5.8.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-cpp/trantor/trantor-1.5.8.ebuild b/dev-cpp/trantor/trantor-1.5.8.ebuild
index f28b11d3f..9aad885bb 100644
--- a/dev-cpp/trantor/trantor-1.5.8.ebuild
+++ b/dev-cpp/trantor/trantor-1.5.8.ebuild
@@ -25,6 +25,11 @@ DEPEND="
"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
+src_prepare() {
+ sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
+ cmake_src_prepare
+}
+
src_configure() {
local -a mycmakeargs=(
"-DBUILD_SHARED_LIBS=YES"