aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-12 00:06:53 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-12 00:06:53 +0100
commit36e0ba2794183bf6225a1a144aad15cda81dc3e6 (patch)
tree0b5b6964d460c3d62544aa18b6a496402c5f0156 /dev-cpp
parentapp-shells/zsh-async: drop 1.8.5 (diff)
downloadguru-36e0ba2794183bf6225a1a144aad15cda81dc3e6.tar.gz
guru-36e0ba2794183bf6225a1a144aad15cda81dc3e6.tar.bz2
guru-36e0ba2794183bf6225a1a144aad15cda81dc3e6.zip
dev-cpp/coeurl: add 0.3.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/coeurl/Manifest1
-rw-r--r--dev-cpp/coeurl/coeurl-0.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/coeurl/Manifest b/dev-cpp/coeurl/Manifest
index 27d5eba4b..d2908a8b5 100644
--- a/dev-cpp/coeurl/Manifest
+++ b/dev-cpp/coeurl/Manifest
@@ -1,2 +1,3 @@
DIST coeurl-0.2.0.tar.bz2 45520 BLAKE2B 8a26f43817af213971c6c8d568251f3306857d9fa8ebdd09aa0a1f548c31b00fe1431334ff546ab152edd002f56d23d006240c494ad2ccaf9292afff97583a84 SHA512 de5f405b6993a33cf958996430d0f7a25cccb47488c3c2ce44525630e533a5acd1d630e2293cdae74befc627de81b211b4a9b6d53138f3de1d92f267f016e4fb
DIST coeurl-0.2.1.tar.bz2 45784 BLAKE2B e1280478d6112171e387d88f10ef220ac839e9be3b222c60111f0e046b00161f29561fce5bc62cc806bd0188fa2ad64f54d016e04e53af9032e69b6cc8dd4153 SHA512 0e65c1120eb352d75976a2b1f11a83dea4e6557276b22962c37e6387bf649ad18117f6f4b4b1b76d4cce2ef53d55834aacf7207e7c15e015344f3c4a60a49671
+DIST coeurl-0.3.0.tar.bz2 46292 BLAKE2B e00e70da3759fa6479d703af8bb520e96f41cbfdd9dc35c2b982f12ca9d596516283d56749785c6862e081b832a29a8453a3a57251c4c968724ed20ccf98d080 SHA512 4ad5a279689ad360f7b33f110e3bf174578655ab036405789d43bcbc73f775c51ab69cb20e79e1229ba045414a2d46e97869a0cd62b978e518cdf23a86b0a846
diff --git a/dev-cpp/coeurl/coeurl-0.3.0.ebuild b/dev-cpp/coeurl/coeurl-0.3.0.ebuild
new file mode 100644
index 000000000..c80a52c33
--- /dev/null
+++ b/dev-cpp/coeurl/coeurl-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A simple async wrapper around CURL for C++"
+HOMEPAGE="https://nheko.im/nheko-reborn/coeurl"
+SRC_URI="https://nheko.im/nheko-reborn/coeurl/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="ssl test"
+RESTRICT="test" # Tests turned off because they need a local webserver.
+
+RDEPEND="
+ net-misc/curl[ssl?]
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ dev-libs/spdlog:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}