aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-09-07 20:51:12 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-09-07 23:23:40 +0200
commitf202c34f9aaef90114494c8ffe7c0d69fadd9241 (patch)
treec71401dca290c86ad49a4173d5a3219b0e3763d4 /dev-cpp
parentmail-client/mailspring-bin: version bump to 1.10.5 (diff)
downloadguru-f202c34f9aaef90114494c8ffe7c0d69fadd9241.tar.gz
guru-f202c34f9aaef90114494c8ffe7c0d69fadd9241.tar.bz2
guru-f202c34f9aaef90114494c8ffe7c0d69fadd9241.zip
dev-cpp/trantor: add 1.5.6_p20220801
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.6_p20220801.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index b79498b2c..1807896af 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1 +1,2 @@
DIST trantor-1.5.6.tar.gz 109719 BLAKE2B 5465f1cddd014a9dee4dd1ea1f8e6f36a1eef3a16424305ff2102fb489838260b415d92e43d72a3fe99db924946987e8e8c64f6720488c2e9e0f42b1b031ca0a SHA512 9c9827b1640fa23f2941c6c10ffe692d4207595de1cb149f94140c0f20d4fe6c45e3efcc50d464bd40aff80443dfe3bdd8db263302755ab8f639a920e497c0b3
+DIST trantor-1.5.6_p20220801.tar.gz 109915 BLAKE2B f9ef51274e2f67a474239482013ab0460265ed60238ada88d1a6aeb3b3883992424a2aa75c4726e8018083c54fef7f2fb5f3fbb781a1feecfd84e2b187937fc8 SHA512 fb1517eeaaf6a3f374e24767cc64183bc8966635f78d37ba213b2aeeef54b9763c59e376fb42b38892fc0468708e940a421d81f4b5809bfe65404e1e75ffa5ad
diff --git a/dev-cpp/trantor/trantor-1.5.6_p20220801.ebuild b/dev-cpp/trantor/trantor-1.5.6_p20220801.ebuild
new file mode 100644
index 000000000..824139348
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.6_p20220801.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_COMMIT="7d9f232c412ad697a4ace35c8b5f7fe22f46124d"
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="adns doc +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares:= )
+ ssl? ( dev-libs/openssl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_SHARED_LIBS=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ "$(cmake_use_find_package ssl OpenSSL)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_install
+}