aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-09 16:07:15 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-15 22:34:20 +0200
commit892262d061f1309b47ecb27f770625958df354df (patch)
tree208e763e5f02a8358da11735ada72b3d17cb5fe5 /dev-ml/systemd
parentdev-ml/tar: initial import (diff)
downloadguru-892262d061f1309b47ecb27f770625958df354df.tar.gz
guru-892262d061f1309b47ecb27f770625958df354df.tar.bz2
guru-892262d061f1309b47ecb27f770625958df354df.zip
dev-ml/systemd: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml/systemd')
-rw-r--r--dev-ml/systemd/Manifest1
-rw-r--r--dev-ml/systemd/metadata.xml11
-rw-r--r--dev-ml/systemd/systemd-1.2.ebuild48
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/systemd/Manifest b/dev-ml/systemd/Manifest
new file mode 100644
index 000000000..a935d689a
--- /dev/null
+++ b/dev-ml/systemd/Manifest
@@ -0,0 +1 @@
+DIST systemd-1.2.tar.gz 47912 BLAKE2B b41e5e38f4bce5460449fec46755ea37ffddf8c30b0459f2d70f4714c6f63dffd62c67ed44cb8385e67243b4e0518f1626f5340e24112730c1d058b5a1d30f99 SHA512 a04cb75a425882af95a31a22643cea5620d3f6683c099f9a21e250f1935143db85b12637a8636842463e25b18a18df389026b6950931015f2e612c6c407c67a4
diff --git a/dev-ml/systemd/metadata.xml b/dev-ml/systemd/metadata.xml
new file mode 100644
index 000000000..e4a496827
--- /dev/null
+++ b/dev-ml/systemd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">juergenhoetzel/ocaml-systemd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/systemd/systemd-1.2.ebuild b/dev-ml/systemd/systemd-1.2.ebuild
new file mode 100644
index 000000000..e9aa7435f
--- /dev/null
+++ b/dev-ml/systemd/systemd-1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+MY_P="ocaml-${P}"
+
+DESCRIPTION="OCaml module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/juergenhoetzel/ocaml-systemd"
+SRC_URI="https://github.com/juergenhoetzel/ocaml-${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RDEPEND="sys-apps/systemd"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+OPAM_FILE=opam
+
+src_configure() {
+ myconf=(
+ --prefix "/usr"
+ --destdir "${D}"
+ --libdir "/usr/$(get_libdir)"
+ --docdir "/usr/share/doc/${PF}"
+ --htmldir "/usr/share/doc/${PF}/html"
+ --override debug false
+ --override is_native $(usex ocamlopt true false)
+ )
+ ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+}