aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2021-02-20 15:44:13 +0100
committerMaciej Barć <xgqt@protonmail.com>2021-02-20 15:44:13 +0100
commitf61690576885d1a9b6b606582bf4677e97dafd3a (patch)
tree4d098f71e5b7bcc2b1fe4bc08c233abc75466c79 /dev-python/convertdate
parentdev-python/pymeeus: bump to 0.3.13 (diff)
downloadguru-f61690576885d1a9b6b606582bf4677e97dafd3a.tar.gz
guru-f61690576885d1a9b6b606582bf4677e97dafd3a.tar.bz2
guru-f61690576885d1a9b6b606582bf4677e97dafd3a.zip
dev-python/convertdate: bump to 2.3.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
Diffstat (limited to 'dev-python/convertdate')
-rw-r--r--dev-python/convertdate/Manifest1
-rw-r--r--dev-python/convertdate/convertdate-2.3.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/convertdate/Manifest b/dev-python/convertdate/Manifest
index c6fd58c2d..fbc96d310 100644
--- a/dev-python/convertdate/Manifest
+++ b/dev-python/convertdate/Manifest
@@ -1 +1,2 @@
DIST convertdate-2.3.0.tar.gz 48993 BLAKE2B d0bbb68eeb71090fc9e0d524a1ec40789d101e29b85c8d3ecc14acefa00ff749f08e74980f36a486b19c08d949a517f00dcb4abc4a8aa29d105b8873e19c470c SHA512 ec3df742f16cdaca49f519d25b6a9647e654b7dd5c3e2ef43f4ae6466dff520db5ab67f58caf066a719e6c8c16b09ed4bf7c27d256259deb7e50f19ea14603f2
+DIST convertdate-2.3.1.tar.gz 49003 BLAKE2B 92410c16b7ac2ae20d1564cb0666c89a2413ae1cc85d29a80c73d9941a712c37791702c0e0ec6b19b018e2bd5c1b7c196cdc7cdfabf362e271e8919bfcc72a71 SHA512 85ec8edc1eafcace2dc1a6a49c8c6fa21ed6119fa7020240eb395cdfd432189349c20484ade3e00f38aec37a95f3042db1bd8955d41ea01f646ec8fafeb60a5c
diff --git a/dev-python/convertdate/convertdate-2.3.1.ebuild b/dev-python/convertdate/convertdate-2.3.1.ebuild
new file mode 100644
index 000000000..e9b79dcd4
--- /dev/null
+++ b/dev-python/convertdate/convertdate-2.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utils for converting between date formats and calculating holidays"
+HOMEPAGE="https://github.com/fitnr/convertdate"
+SRC_URI="https://github.com/fitnr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pymeeus[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme