aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-07-01 17:01:54 +0200
committerDavid Roman <davidroman96@gmail.com>2024-07-01 17:01:54 +0200
commit4ac701d3bf5d37692e66ef9a9ae93528bac95229 (patch)
tree3f8b61a8bf8e85dae77cf7761880e8aac948fbd9 /dev-python/jplephem/jplephem-2.22.ebuild
parentdev-python/plexapi: add 4.15.14 (diff)
downloadguru-4ac701d3bf5d37692e66ef9a9ae93528bac95229.tar.gz
guru-4ac701d3bf5d37692e66ef9a9ae93528bac95229.tar.bz2
guru-4ac701d3bf5d37692e66ef9a9ae93528bac95229.zip
dev-python/jplephem: add 2.22
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/jplephem/jplephem-2.22.ebuild')
-rw-r--r--dev-python/jplephem/jplephem-2.22.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jplephem/jplephem-2.22.ebuild b/dev-python/jplephem/jplephem-2.22.ebuild
new file mode 100644
index 000000000..153b47937
--- /dev/null
+++ b/dev-python/jplephem/jplephem-2.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python version of NASA DE4xx ephemerides for Astronomical Alamanac"
+HOMEPAGE="https://pypi.org/project/jplephem/"
+SRC_URI="https://github.com/brandon-rhodes/python-jplephem/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-fix-numpy-compat.patch" )
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd ci || die
+ eunittest .
+}