aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-03 12:40:48 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-03 12:40:48 +0200
commit32cdad40cc948eca4f4ba21a20fece291757fb3d (patch)
tree0a4205f9f72ba2325e0c7940fe173d9cb4f2f329 /dev-python/manhole
parentdev-python/pytest-subtests: fix tests if pakcage ... (diff)
downloadguru-32cdad40cc948eca4f4ba21a20fece291757fb3d.tar.gz
guru-32cdad40cc948eca4f4ba21a20fece291757fb3d.tar.bz2
guru-32cdad40cc948eca4f4ba21a20fece291757fb3d.zip
dev-python/manhole: die if tests fail
also, if you dont want distutils_enable_tests to overwrite your custom test function just put distutils_enable_tests before the python_test function Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/manhole-1.6.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/manhole/manhole-1.6.0.ebuild b/dev-python/manhole/manhole-1.6.0.ebuild
index b60509bf5..f452da169 100644
--- a/dev-python/manhole/manhole-1.6.0.ebuild
+++ b/dev-python/manhole/manhole-1.6.0.ebuild
@@ -16,10 +16,9 @@ HOMEPAGE="
https://pypi.org/project/python-manhole
"
SRC_URI="https://github.com/ionelmc/${MYPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="BSD-2"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
KEYWORDS="~amd64 ~x86"
RDEPEND=""
@@ -37,6 +36,11 @@ DEPEND="
S="${WORKDIR}/${MYPN}-${PV}"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme \
+ dev-python/sphinxcontrib-napoleon
+
python_test() {
pytest -vv \
--deselect tests/test_manhole.py::test_non_daemon_connection \
@@ -45,10 +49,6 @@ python_test() {
--deselect tests/test_manhole.py::test_fork_exec \
--deselect tests/test_manhole.py::test_connection_handler_exec[str] \
--deselect tests/test_manhole.py::test_connection_handler_exec[func] \
- --deselect tests/test_manhole_cli.py::test_help
+ --deselect tests/test_manhole_cli.py::test_help || die
}
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme \
- dev-python/sphinxcontrib-napoleon