aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-22 19:01:27 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-22 19:01:27 +0500
commite1853a1c140b039ae775f23bca3e54ac884fc836 (patch)
tree944045a0b30c41110733ab7772089fbf7c1b8bea /dev-util
parentdev-python/cryptg: add 0.5.0 (diff)
downloadguru-e1853a1c140b039ae775f23bca3e54ac884fc836.tar.gz
guru-e1853a1c140b039ae775f23bca3e54ac884fc836.tar.bz2
guru-e1853a1c140b039ae775f23bca3e54ac884fc836.zip
dev-util/pifpaf: add 3.2.3, drop 3.1.5-r1
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pifpaf/Manifest2
-rw-r--r--dev-util/pifpaf/files/pifpaf-3.2.3-psql17.patch17
-rw-r--r--dev-util/pifpaf/pifpaf-3.2.3.ebuild (renamed from dev-util/pifpaf/pifpaf-3.1.5-r1.ebuild)19
3 files changed, 30 insertions, 8 deletions
diff --git a/dev-util/pifpaf/Manifest b/dev-util/pifpaf/Manifest
index 54398ceac..0e7e583e4 100644
--- a/dev-util/pifpaf/Manifest
+++ b/dev-util/pifpaf/Manifest
@@ -1,2 +1,2 @@
-DIST pifpaf-3.1.5.tar.gz 189903 BLAKE2B 5742e995feeb91af41db20cc605e8a5f5f21f63281d4f66ba8b108310a88d716ab4be0a43e0371f10e7f3f42b693953b3344c648458999348b914e03abe462c8 SHA512 4e0f70740f8260cb3cf801ea97f1fa30e6b87cfc4112b5482389d0635e76bbc7f1561945397e4e6586116c49d11b1e8f721dd61dca82668833bf224f9ba3e94f
DIST pifpaf-3.2.1.tar.gz 183005 BLAKE2B 4ce210af724bbe615a3ccf0b70cd1eb8f1f3b8e0bba1d80e157bdb96a6f705487283977b86aafd71483c750a0029bb2cd4c65c6b7694d47b539dff86be663572 SHA512 680d034e00b6491e1e7c56524b83be8d1853e41a6c3be0c8f9af5339d9a248f7d3ae21e801c10ccaf2f530ce36f8e33fdbe49196f7add69c9a85c8e89fdc02ac
+DIST pifpaf-3.2.3.tar.gz 185673 BLAKE2B f8e3f953e8f232120f320ee3f6914672c5f16fb9c4345a9391055c3e27169283a462eed745e0c2a337b03f64ba6822484cc9ff3d82c218b2bc5f321bb9432e6a SHA512 cb7f22ed1839e0615ce01414baf6113070a6cec8a6649beb3ea0e588c6d235f4b35c0a8daacafa098b9ba08975f61bb38e0784263aa9cb1037bf60df8b838d5f
diff --git a/dev-util/pifpaf/files/pifpaf-3.2.3-psql17.patch b/dev-util/pifpaf/files/pifpaf-3.2.3-psql17.patch
new file mode 100644
index 000000000..9055d0388
--- /dev/null
+++ b/dev-util/pifpaf/files/pifpaf-3.2.3-psql17.patch
@@ -0,0 +1,17 @@
+Space after "-A" causes the following error in PostgreSQL 17:
+> initdb: error: invalid authentication method " trust" for "local"
+> connections
+
+Commit: https://github.com/jd/pifpaf/commit/0f4abc1306563ccca72bddf89f430fcbd8a7a6e9
+
+--- a/pifpaf/drivers/postgresql.py
++++ b/pifpaf/drivers/postgresql.py
+@@ -53,7 +53,7 @@ class PostgreSQLDriver(drivers.Driver):
+ self.putenv("PGDATABASE", "postgres", True)
+ _, pgbindir = self._exec(["pg_config", "--bindir"], stdout=True)
+ pgctl = os.path.join(pgbindir.strip().decode(), "pg_ctl")
+- self._exec([pgctl, "-o", "'-A trust'", "initdb"])
++ self._exec([pgctl, "-o", "'-Atrust'", "initdb"])
+ if not self.sync:
+ cfgfile = os.path.join(self.tempdir, 'postgresql.conf')
+ with open(cfgfile, 'a') as cfg:
diff --git a/dev-util/pifpaf/pifpaf-3.1.5-r1.ebuild b/dev-util/pifpaf/pifpaf-3.2.3.ebuild
index 3dbf3e812..644981ab7 100644
--- a/dev-util/pifpaf/pifpaf-3.1.5-r1.ebuild
+++ b/dev-util/pifpaf/pifpaf-3.2.3.ebuild
@@ -17,23 +17,21 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-# dev-python/pbr: for pbr.version
-# dev-python/setuptools: for pkg_resources and distutils
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
dev-python/daiquiri[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/xattr[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
app-admin/consul
app-admin/vault
+ dev-db/etcd[server]
dev-db/postgresql[server]
dev-db/redis
dev-python/httpbin[${PYTHON_USEDEP}]
@@ -46,14 +44,21 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.3-psql17.patch
+)
+
EPYTEST_DESELECT=(
# Need updates to new CLIs and APIs
- pifpaf/tests/test_drivers.py::TestDrivers::test_etcd
pifpaf/tests/test_drivers.py::TestDrivers::test_influxdb
pifpaf/tests/test_drivers.py::TestDrivers::test_mongodb
+ pifpaf/tests/test_drivers.py::TestDrivers::test_redis_sentinel
+
+ # RabbitMQ wants to be run only as root
pifpaf/tests/test_drivers.py::TestDrivers::test_rabbitmq
pifpaf/tests/test_drivers.py::TestDrivers::test_rabbitmq_cluster
- pifpaf/tests/test_drivers.py::TestDrivers::test_redis_sentinel
)
distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}