aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-02 20:44:20 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 06:12:51 +0500
commit84dce05a355e98a0d500d2f0b4d86ce8665d0545 (patch)
tree3d18e486e4aba9f1c6cfe7f362acfeba2893373f /dev-vcs
parentnet-misc/ooni-probe-cli: add 3.16.5, drop 3.16.3 (diff)
downloadguru-84dce05a355e98a0d500d2f0b4d86ce8665d0545.tar.gz
guru-84dce05a355e98a0d500d2f0b4d86ce8665d0545.tar.bz2
guru-84dce05a355e98a0d500d2f0b4d86ce8665d0545.zip
dev-vcs/got: add missing dep
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/got/got-0.77-r1.ebuild (renamed from dev-vcs/got/got-0.77.ebuild)25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-vcs/got/got-0.77.ebuild b/dev-vcs/got/got-0.77-r1.ebuild
index f8642b4cf..f7846ca77 100644
--- a/dev-vcs/got/got-0.77.ebuild
+++ b/dev-vcs/got/got-0.77-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit toolchain-funcs
-
MY_PN="${PN}-portable"
DESCRIPTION="Portable version of the Game of Trees version control system"
HOMEPAGE="https://gameoftrees.org"
@@ -16,15 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="
+ dev-libs/libevent:=
sys-libs/ncurses:=[unicode(+)]
sys-libs/zlib:=
- elibc_Darwin? ( dev-libs/ossp-uuid )
- elibc_SunOS? ( sys-libs/libuuid )
- !elibc_Darwin? ( dev-libs/libbsd )
- !elibc_Darwin? ( !elibc_SunOS? (
- app-crypt/libmd
- sys-apps/util-linux
- ) )
+ elibc_Darwin? (
+ dev-libs/ossp-uuid
+ )
+ elibc_SunOS? (
+ sys-libs/libuuid
+ )
+ !elibc_Darwin? (
+ dev-libs/libbsd
+ !elibc_SunOS? (
+ app-crypt/libmd
+ sys-apps/util-linux
+ )
+ )
"
BDEPEND="
virtual/pkgconfig
@@ -36,5 +41,5 @@ RDEPEND="${DEPEND}"
DOCS=( CHANGELOG CHANGES README TODO )
src_compile() {
- emake AR=$(tc-getAR) GOT_RELEASE=Yes
+ emake GOT_RELEASE=Yes
}