aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 03:35:41 +0200
committerGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 03:35:41 +0200
commit4d1f22b64b32761fccd5c5a1e4f60270cc5ad643 (patch)
tree9dc7f9776da21d0cf868f49a5cee087f7038fe2f /gnome-extra
parentnet-voip: removed Calls because it has been switched to gnome-calls (diff)
downloadguru-4d1f22b64b32761fccd5c5a1e4f60270cc5ad643.tar.gz
guru-4d1f22b64b32761fccd5c5a1e4f60270cc5ad643.tar.bz2
guru-4d1f22b64b32761fccd5c5a1e4f60270cc5ad643.zip
gnome-extra/authenticator: Adding for PinePhone use
Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Gerben jan Dijkman <gjdijkman@gjdwebserver.nl>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/authenticator/Manifest1
-rw-r--r--gnome-extra/authenticator/authenticator-4.0.3.ebuild46
-rw-r--r--gnome-extra/authenticator/metadata.xml15
3 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/authenticator/Manifest b/gnome-extra/authenticator/Manifest
new file mode 100644
index 000000000..957a4c22d
--- /dev/null
+++ b/gnome-extra/authenticator/Manifest
@@ -0,0 +1 @@
+DIST authenticator-4.0.3.tar.gz 411473 BLAKE2B aebc1bd99ae78050447495ce99a6379a9358c8cd9469561cb30b8d8fd6ce3d98a1f3e7f966a3a6c9ff8ffcb39893571080eaae601a733e8a4a04a484041de529 SHA512 81900b0a31398597bab9f40a79432d3a3c31fe9eea162a9699c10ff01ba6aba210f1a3e1a70e113090f8aea49a12fd32dac005c7b64f1c73a6cfe56303243186
diff --git a/gnome-extra/authenticator/authenticator-4.0.3.ebuild b/gnome-extra/authenticator/authenticator-4.0.3.ebuild
new file mode 100644
index 000000000..b2841fec8
--- /dev/null
+++ b/gnome-extra/authenticator/authenticator-4.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit vala meson gnome2-utils git-r3 xdg
+
+DESCRIPTION="Simple application for generating Two-Factor Authentication Codes."
+HOMEPAGE="https://gitlab.gnome.org/World/Authenticator"
+SRC_URI="https://gitlab.gnome.org/World/Authenticator/-/archive/${PV}/${PN}-${PV}.tar.gz"
+EGIT_REPO_URI="https://gitlab.gnome.org/World/Authenticator.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ gnome-base/gnome-common
+ gui-libs/gtk
+ x11-libs/libadwaita
+ x11-libs/gdk-pixbuf
+ >=media-libs/gstreamer-1.18.0
+ "
+RDEPEND="${DEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-util/meson
+ dev-libs/gobject-introspection
+ "
+
+S="${WORKDIR}/$PN-${PV}"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/authenticator/metadata.xml b/gnome-extra/authenticator/metadata.xml
new file mode 100644
index 000000000..be6935ede
--- /dev/null
+++ b/gnome-extra/authenticator/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gjdijkman@gjdwebserver.nl</email>
+ <name>Gerben Jan Dijkman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Generate Two-Factor Codes.
+ </longdescription>
+ <upstream>
+ <doc>https://gitlab.gnome.org/World/Authenticator</doc>
+ <bugs-to>https://gitlab.gnome.org/World/Authenticator/-/issues</bugs-to>
+ </upstream>
+</pkgmetadata>