aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 03:16:16 +0200
committerGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 03:16:16 +0200
commitfb77006265cfe906af73b76904b44dfcdd262df7 (patch)
tree97a8b80d798474e8b91c92229e89bcb999fe1a69 /gnome-extra
parentdev-libs/libphonenumber: Adding for PinePhone applications (diff)
downloadguru-fb77006265cfe906af73b76904b44dfcdd262df7.tar.gz
guru-fb77006265cfe906af73b76904b44dfcdd262df7.tar.bz2
guru-fb77006265cfe906af73b76904b44dfcdd262df7.zip
gnome-extra/evolution-data-server: Adding to guru for PhoneNumber support added
Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Gerben jan Dijkman <gjdijkman@gjdwebserver.nl>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.40.3.ebuild155
-rw-r--r--gnome-extra/evolution-data-server/files/3.36.5-gtk-doc-1.32-compat.patch32
-rw-r--r--gnome-extra/evolution-data-server/files/calentry.schema108
-rw-r--r--gnome-extra/evolution-data-server/metadata.xml262
5 files changed, 558 insertions, 0 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
new file mode 100644
index 000000000..b80213d77
--- /dev/null
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -0,0 +1 @@
+DIST evolution-data-server-3.40.3.tar.xz 4625980 BLAKE2B 7b344c1bb279367c9eca136b9f4689f049ba126b9ffd6ba1a1a819c5f86db66bae4082ebab83c8895831e97a4ed4384bb923584146b6081ffbbc24c327d5f3d4 SHA512 ba5db9850d68c23ddc77e53ccb2500f613dcdc5689234b3365edbc97eb6e73c4f15c13df5dee0b2aab1d0af5a22d543c6aeb814c4abfe1dc652b46712c0e2e79
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.40.3.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.40.3.ebuild
new file mode 100644
index 000000000..1728d0670
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.40.3.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit cmake db-use flag-o-matic gnome2 systemd vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/62-26-20" # subslot = libcamel-1.2/libedataserver-1.2/libebook-1.2.so soname version
+
+IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ipv6 ldap kerberos oauth vala +weather phonenumber"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+# gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
+# berkdb needed only for migrating old addressbook data from <3.13 versions, bug #519512
+gdata_depend=">=dev-libs/libgdata-0.17.7:=[vala?]"
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.8:=[glib,introspection?]
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.58:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.16:3
+ >=media-libs/libcanberra-0.25[gtk3]
+ )
+ oauth? (
+ >=dev-libs/json-glib-1.0.4
+ >=net-libs/webkit-gtk-2.28.0:4
+ ${gdata_depend}
+ )
+ phonenumber? (
+ >=dev-libs/libphonenumber-8.12.24
+ )
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.8:=
+ ${gdata_depend} )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend)
+ net-libs/libsoup:2.4[vala]
+ dev-libs/libical[vala]
+ )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Some tests fail due to missing locales.
+# Also, dbus tests are flaky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
+src_prepare() {
+ use vala && vala_src_prepare
+ cmake_src_prepare
+ gnome2_src_prepare
+
+ eapply "${FILESDIR}"/3.36.5-gtk-doc-1.32-compat.patch
+
+ # Make CMakeLists versioned vala enabled
+ sed -e "s;\(find_program(VALAC\) valac);\1 ${VALAC});" \
+ -e "s;\(find_program(VAPIGEN\) vapigen);\1 ${VAPIGEN});" \
+ -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ local google_enable
+ if use oauth || use gnome-online-accounts; then
+ google_enable="ON"
+ else
+ google_enable="OFF"
+ fi
+
+ # phonenumber does not exist in tree
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_PRIVATE_DOCS=$(usex gtk-doc)
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DWITH_KRB5=$(usex kerberos)
+ -DWITH_KRB5_INCLUDES=$(usex kerberos "${EPREFIX}"/usr "")
+ -DWITH_KRB5_LIBS=$(usex kerberos "${EPREFIX}"/usr/$(get_libdir) "")
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DWITH_PHONENUMBER=$(usex phonenumber)
+ -DENABLE_SMIME=ON
+ -DENABLE_GTK=$(usex gtk)
+ -DENABLE_CANBERRA=$(usex gtk)
+ -DENABLE_OAUTH2=$(usex oauth)
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_GOA=$(usex gnome-online-accounts)
+ -DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
+ # ENABLE_BACKTRACES requires libdwarf ?
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_GOOGLE=${google_enable}
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_VALA_BINDINGS=$(usex vala)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym ../../../usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
diff --git a/gnome-extra/evolution-data-server/files/3.36.5-gtk-doc-1.32-compat.patch b/gnome-extra/evolution-data-server/files/3.36.5-gtk-doc-1.32-compat.patch
new file mode 100644
index 000000000..3a202bee1
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/3.36.5-gtk-doc-1.32-compat.patch
@@ -0,0 +1,32 @@
+From 24c7ca17eaf69211b75f2882c11aeff01a3cad01 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 8 Aug 2020 18:59:25 +0300
+Subject: [PATCH] I#158 - Workaround build error with gtk-doc-1.32
+
+---
+ src/calendar/libecal/e-cal-time-util.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/calendar/libecal/e-cal-time-util.h b/src/calendar/libecal/e-cal-time-util.h
+index 8acb13061..11c9d3369 100644
+--- a/src/calendar/libecal/e-cal-time-util.h
++++ b/src/calendar/libecal/e-cal-time-util.h
+@@ -150,6 +150,7 @@ void time_to_gdate_with_zone (GDate *date,
+ * struct tm manipulation
+ **************************************************************************/
+
++#ifndef __GTK_DOC_IGNORE__
+ struct tm e_cal_util_icaltime_to_tm
+ (const ICalTime *itt);
+ struct tm e_cal_util_icaltime_to_tm_with_zone
+@@ -159,6 +160,7 @@ struct tm e_cal_util_icaltime_to_tm_with_zone
+ ICalTime * e_cal_util_tm_to_icaltime
+ (struct tm *tm,
+ gboolean is_date);
++#endif
+
+ G_END_DECLS
+
+--
+2.20.1
+
diff --git a/gnome-extra/evolution-data-server/files/calentry.schema b/gnome-extra/evolution-data-server/files/calentry.schema
new file mode 100644
index 000000000..bc79da273
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/calentry.schema
@@ -0,0 +1,108 @@
+# RFC2739 calEntry schema for OpenLDAP 2.x
+
+#
+# From https://bugs.gentoo.org/show_bug.cgi?id=83988
+# Please notify us of updated revisions by submitting a bug report at bugs.gentoo.org
+#
+
+# Version of RFC 2739 schema translated by Terrelle Shaw
+# (xytek@xytek.org) # Nov. 7, 2002 # Modifications by Peter Marschall
+# <peter.marschall@adpm.de> # Nov. 9, 2002
+
+# Notes:
+# * RFC2739 seems to be a bit sloppy about attribute type and
+# objectclass definitions syntax and also about attribute syntax
+# and matching rules.
+# (It even counts the attributes in the calEntry objectclass wrong ;-)
+# * The following changes have been applied to correct the schema
+# - added description to each attributetype definition
+# - changed SYNTAX from 'IA5String' to corresponding OID
+# to make matching rules and syntax consistent
+# - replaced illegal keyword SUBSTRING by SUBSTR
+# - changed SUBSTR from caseIgnoreIA5Match to caseIgnoreIA5SubstringsMatch
+# - removed illegal keyword MULTI-VALUE
+# - added keyword SINGLE-VALUE where appropriate
+# - removed USAGE since cwuserApplications is the default
+# - added description to the objectclass defintion
+# - corrected typo in objectclass definition
+# - added the attributetypes defined but not used to the objectclass
+
+
+# 2.4.4.1 calCalURI
+attributetype ( 1.2.840.113556.1.4.478
+ NAME 'calCalURI'
+ DESC 'URI to a snapshot of the users entire default calendar'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26
+ SINGLE-VALUE )
+
+# 2.4.4.2 calFBURL
+attributetype ( 1.2.840.113556.1.4.479
+ NAME 'calFBURL'
+ DESC 'URI to the users default free/busy time data'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26
+ SINGLE-VALUE )
+
+# 2.4.4.3 calCAPURI
+attributetype ( 1.2.840.113556.1.4.480
+ NAME 'calCAPURI'
+ DESC 'URI used to communicate with the users calendar'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26
+ SINGLE-VALUE )
+
+# 2.4.4.4 calCalAdrURI
+attributetype ( 1.2.840.113556.1.4.481
+ NAME 'calCalAdrURI'
+ DESC 'URI to which event requests should be sent for the user'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26
+ SINGLE-VALUE )
+
+# 2.4.4.5 calOtherCalURIs
+attributetype ( 1.2.840.113556.1.4.482
+ NAME 'calOtherCalURIs'
+ DESC 'URIs to snapshots of non-default calendars belonging to the user'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 )
+
+# 2.4.4.6 calOtherFBURLs
+attributetype ( 1.2.840.113556.1.4.483
+ NAME 'calOtherFBURLs'
+ DESC 'URIs to non-default free/busy data belonging to the user'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 )
+
+# 2.4.4.7 calOtherCAPURIs
+attributetype ( 1.2.840.113556.1.4.484
+ NAME 'calOtherCAPURIs'
+ DESC 'URIs to non-default calendars belonging to the user'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 )
+
+# 2.4.4.8 calOtherCalAdrURIs
+attributetype ( 1.2.840.113556.1.4.485
+ NAME 'calOtherCalAdrURIs'
+ DESC 'URIs of destinations for event requests to non-default calendars'
+ EQUALITY caseIgnoreIA5Match
+ SUBSTR caseIgnoreIA5SubstringsMatch
+ SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 )
+
+# 2.4.3.1 calEntry
+objectclass ( 1.2.840.113556.1.5.87
+ NAME 'calEntry'
+ DESC 'Calendering and free/busy information'
+ SUP top AUXILIARY
+ MAY ( calCalURI $ calFBURL $ calCAPURI $ calCalAdrURI $
+ calOtherCAPURIs $ calOtherCalURIs $ calOtherFBURLs $
+ calOtherCalAdrURIs ) )
+
+# EOF
diff --git a/gnome-extra/evolution-data-server/metadata.xml b/gnome-extra/evolution-data-server/metadata.xml
new file mode 100644
index 000000000..d8cbee0e0
--- /dev/null
+++ b/gnome-extra/evolution-data-server/metadata.xml
@@ -0,0 +1,262 @@
+<!DOCTYPE html>
+<html lang='en'>
+<head>
+<title>metadata.xml « evolution-data-server « gnome-extra - repo/gentoo.git - Official Gentoo ebuild repository</title>
+<meta name='generator' content='cgit v1.2.3-18-g5258'/>
+<meta name='robots' content='index,follow'/>
+<link rel='stylesheet' type='text/css' href='/cgit.css'/>
+<link rel='shortcut icon' href='//www.gentoo.org/favicon.ico'/>
+<link rel='alternate' title='Atom feed' href='https://gitweb.gentoo.org/repo/gentoo.git/atom/gnome-extra/evolution-data-server/metadata.xml?h=master' type='application/atom+xml'/>
+<link rel='vcs-git' href='https://anongit.gentoo.org/git/repo/gentoo.git' title='repo/gentoo.git Git repository'/>
+<link rel='vcs-git' href='git+ssh://git@git.gentoo.org/repo/gentoo.git' title='repo/gentoo.git Git repository'/>
+<meta name="viewport" content="width=device-width, initial-scale=1.0">
+<meta name="theme-color" content="#54487a">
+<meta name="description" content="Browse the Gentoo Git repositories">
+<link href="https://assets.gentoo.org/tyrian/v2/tyrian.min.css" rel="stylesheet" media="screen">
+</head>
+<body>
+<header>
+ <div class="site-title">
+ <div class="container">
+ <div class="row justify-content-between">
+ <div class="logo">
+ <a href="/" title="Back to the homepage" class="site-logo">
+ <img src="https://assets.gentoo.org/tyrian/v2/site-logo.png" alt="Gentoo" srcset="https://assets.gentoo.org/tyrian/v2/site-logo.svg">
+ </a>
+ <span class="site-label">GitWeb</span>
+ </div>
+ <div class="site-title-buttons">
+ <div class="btn-group btn-group-sm">
+ <a href="https://get.gentoo.org/" role="button" class="btn get-gentoo"><span class="fa fa-fw fa-download"></span>
+ <strong>Get Gentoo!</strong></a>
+ <div class="btn-group btn-group-sm">
+ <a class="btn gentoo-org-sites dropdown-toggle" data-toggle="dropdown" data-target="#" href="#">
+ <span class="fa fa-fw fa-map-o"></span> <span class="d-none d-sm-inline">gentoo.org sites</span>
+ <span class="caret"></span>
+ </a>
+ <div class="dropdown-menu dropdown-menu-right">
+ <a class="dropdown-item" href="https://www.gentoo.org/" title="Main Gentoo website"><span class="fa fa-home fa-fw"></span>
+ gentoo.org</a>
+ <a class="dropdown-item" href="https://wiki.gentoo.org/" title="Find and contribute documentation"><span class="fa fa-file-text-o fa-fw"></span>
+ Wiki</a>
+ <a class="dropdown-item" href="https://bugs.gentoo.org/" title="Report issues and find common issues"><span class="fa fa-bug fa-fw"></span>
+ Bugs</a>
+ <a class="dropdown-item" href="https://forums.gentoo.org/" title="Discuss with the community"><span class="fa fa-comments-o fa-fw"></span>
+ Forums</a>
+ <a class="dropdown-item" href="https://packages.gentoo.org/" title="Find software for your Gentoo"><span class="fa fa-hdd-o fa-fw"></span>
+ Packages</a>
+ <div class="dropdown-divider"></div>
+ <a class="dropdown-item" href="https://planet.gentoo.org/" title="Find out what's going on in the developer community"><span class="fa fa-rss fa-fw"></span>
+ Planet</a>
+ <a class="dropdown-item" href="https://archives.gentoo.org/" title="Read up on past discussions"><span class="fa fa-archive fa-fw"></span>
+ Archives</a>
+ <a class="dropdown-item" href="https://sources.gentoo.org/" title="Browse our source code"><span class="fa fa-code fa-fw"></span>
+ Sources</a>
+ <div class="dropdown-divider"></div>
+ <a class="dropdown-item" href="https://infra-status.gentoo.org/" title="Get updates on the services provided by Gentoo"><span class="fa fa-server fa-fw"></span>
+ Infra Status</a>
+ </div>
+ </div>
+ </div>
+ </div>
+ </div>
+ </div>
+ </div>
+ <nav class="tyrian-navbar navbar navbar-dark navbar-expand-lg bg-primary" role="navigation">
+ <div class="container">
+ <div class="navbar-header">
+ <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-main-collapse" aria-controls="navbar-main-collapse" aria-expanded="false" aria-label="Toggle navigation">
+ <span class="navbar-toggler-icon"></span>
+ </button>
+ </div>
+ <div class="collapse navbar-collapse navbar-main-collapse" id="navbar-main-collapse">
+ <ul class="navbar-nav mr-auto">
+ <li class="nav-item"><a class="nav-link" href="/">Home</a></li>
+ <li class="nav-item"><a class="nav-link" href="/repo/gentoo.git">Gentoo Repository</a></li>
+ <li class="nav-item"><a class="nav-link" href="/repo/">Repositories</a></li>
+ <li class="nav-item"><a class="nav-link" href="/proj/">Projects</a></li>
+ <li class="nav-item"><a class="nav-link" href="/dev/">Developer Overlays</a></li>
+ <li class="nav-item"><a class="nav-link" href="/user/">User Overlays</a></li>
+ <li class="nav-item"><a class="nav-link" href="/data/">Data</a></li>
+ <li class="nav-item"><a class="nav-link" href="/sites/">Websites</a></li>
+ </ul>
+ </div>
+ </div>
+ </nav>
+</header>
+
+<div class="container pb-5">
+ <div class="row">
+ <div class="col-md-12">
+<div id='cgit'><table id='header'>
+<tr>
+<td class='logo' rowspan='2'><a href='/'><img src='/cgit.png' alt='cgit logo'/></a></td>
+<td class='main'><a href='/'>index</a> : <a title='repo/gentoo.git' href='/repo/gentoo.git/'>repo/gentoo.git</a></td><td class='form'><form method='get'>
+<select name='h' onchange='this.form.submit();'>
+<option value='master' selected='selected'>master</option>
+</select> <input type='submit' value='switch'/></form></td></tr>
+<tr><td class='sub'>Official Gentoo ebuild repository</td><td class='sub right'>Infrastructure team &lt;infrastructure@gentoo.org&gt;</td></tr></table>
+<table class='tabs'><tr><td>
+<a href='/repo/gentoo.git/'>summary</a><a href='/repo/gentoo.git/refs/'>refs</a><a href='/repo/gentoo.git/log/gnome-extra/evolution-data-server/metadata.xml'>log</a><a class='active' href='/repo/gentoo.git/tree/gnome-extra/evolution-data-server/metadata.xml'>tree</a><a href='/repo/gentoo.git/commit/gnome-extra/evolution-data-server/metadata.xml'>commit</a><a href='/repo/gentoo.git/diff/gnome-extra/evolution-data-server/metadata.xml'>diff</a></td><td class='form'><form class='right' method='get' action='/repo/gentoo.git/log/gnome-extra/evolution-data-server/metadata.xml'>
+<select name='qt'>
+<option value='grep'>log msg</option>
+<option value='author'>author</option>
+<option value='committer'>committer</option>
+<option value='range'>range</option>
+</select>
+<input class='txt' type='search' size='10' name='q' value=''/>
+<input type='submit' value='search'/>
+</form>
+</td></tr></table>
+<div class='path'>path: <a href='/repo/gentoo.git/tree/'>root</a>/<a href='/repo/gentoo.git/tree/gnome-extra'>gnome-extra</a>/<a href='/repo/gentoo.git/tree/gnome-extra/evolution-data-server'>evolution-data-server</a>/<a href='/repo/gentoo.git/tree/gnome-extra/evolution-data-server/metadata.xml'>metadata.xml</a></div><div class='content'>blob: b2c06af5a423d5dce5a2c6115241188528e79a2c (<a href='/repo/gentoo.git/plain/gnome-extra/evolution-data-server/metadata.xml'>plain</a>)
+<table summary='blob content' class='blob'>
+<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
+<a id='n2' href='#n2'>2</a>
+<a id='n3' href='#n3'>3</a>
+<a id='n4' href='#n4'>4</a>
+<a id='n5' href='#n5'>5</a>
+<a id='n6' href='#n6'>6</a>
+<a id='n7' href='#n7'>7</a>
+<a id='n8' href='#n8'>8</a>
+<a id='n9' href='#n9'>9</a>
+<a id='n10' href='#n10'>10</a>
+<a id='n11' href='#n11'>11</a>
+<a id='n12' href='#n12'>12</a>
+<a id='n13' href='#n13'>13</a>
+<a id='n14' href='#n14'>14</a>
+<a id='n15' href='#n15'>15</a>
+<a id='n16' href='#n16'>16</a>
+</pre></td>
+<td class='lines'><pre><code><style>pre { line-height: 125%; }
+td.linenos pre { color: #000000; background-color: #f0f0f0; padding-left: 5px; padding-right: 5px; }
+span.linenos { color: #000000; background-color: #f0f0f0; padding-left: 5px; padding-right: 5px; }
+td.linenos pre.special { color: #000000; background-color: #ffffc0; padding-left: 5px; padding-right: 5px; }
+span.linenos.special { color: #000000; background-color: #ffffc0; padding-left: 5px; padding-right: 5px; }
+.highlight .hll { background-color: #ffffcc }
+.highlight .c { color: #888888 } /* Comment */
+.highlight .err { color: #a61717; background-color: #e3d2d2 } /* Error */
+.highlight .k { color: #008800; font-weight: bold } /* Keyword */
+.highlight .ch { color: #888888 } /* Comment.Hashbang */
+.highlight .cm { color: #888888 } /* Comment.Multiline */
+.highlight .cp { color: #cc0000; font-weight: bold } /* Comment.Preproc */
+.highlight .cpf { color: #888888 } /* Comment.PreprocFile */
+.highlight .c1 { color: #888888 } /* Comment.Single */
+.highlight .cs { color: #cc0000; font-weight: bold; background-color: #fff0f0 } /* Comment.Special */
+.highlight .gd { color: #000000; background-color: #ffdddd } /* Generic.Deleted */
+.highlight .ge { font-style: italic } /* Generic.Emph */
+.highlight .gr { color: #aa0000 } /* Generic.Error */
+.highlight .gh { color: #333333 } /* Generic.Heading */
+.highlight .gi { color: #000000; background-color: #ddffdd } /* Generic.Inserted */
+.highlight .go { color: #888888 } /* Generic.Output */
+.highlight .gp { color: #555555 } /* Generic.Prompt */
+.highlight .gs { font-weight: bold } /* Generic.Strong */
+.highlight .gu { color: #666666 } /* Generic.Subheading */
+.highlight .gt { color: #aa0000 } /* Generic.Traceback */
+.highlight .kc { color: #008800; font-weight: bold } /* Keyword.Constant */
+.highlight .kd { color: #008800; font-weight: bold } /* Keyword.Declaration */
+.highlight .kn { color: #008800; font-weight: bold } /* Keyword.Namespace */
+.highlight .kp { color: #008800 } /* Keyword.Pseudo */
+.highlight .kr { color: #008800; font-weight: bold } /* Keyword.Reserved */
+.highlight .kt { color: #888888; font-weight: bold } /* Keyword.Type */
+.highlight .m { color: #0000DD; font-weight: bold } /* Literal.Number */
+.highlight .s { color: #dd2200; background-color: #fff0f0 } /* Literal.String */
+.highlight .na { color: #336699 } /* Name.Attribute */
+.highlight .nb { color: #003388 } /* Name.Builtin */
+.highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */
+.highlight .no { color: #003366; font-weight: bold } /* Name.Constant */
+.highlight .nd { color: #555555 } /* Name.Decorator */
+.highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */
+.highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */
+.highlight .nl { color: #336699; font-style: italic } /* Name.Label */
+.highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */
+.highlight .py { color: #336699; font-weight: bold } /* Name.Property */
+.highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */
+.highlight .nv { color: #336699 } /* Name.Variable */
+.highlight .ow { color: #008800 } /* Operator.Word */
+.highlight .w { color: #bbbbbb } /* Text.Whitespace */
+.highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */
+.highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */
+.highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */
+.highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */
+.highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */
+.highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */
+.highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */
+.highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */
+.highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */
+.highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */
+.highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */
+.highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */
+.highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */
+.highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */
+.highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */
+.highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */
+.highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */
+.highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */
+.highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */
+.highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */
+.highlight .vc { color: #336699 } /* Name.Variable.Class */
+.highlight .vg { color: #dd7700 } /* Name.Variable.Global */
+.highlight .vi { color: #3333bb } /* Name.Variable.Instance */
+.highlight .vm { color: #336699 } /* Name.Variable.Magic */
+.highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */</style><div class="highlight"><pre><span></span><span class="cp">&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;</span>
+<span class="cp">&lt;!DOCTYPE pkgmetadata SYSTEM &quot;http://www.gentoo.org/dtd/metadata.dtd&quot;&gt;</span>
+<span class="nt">&lt;pkgmetadata&gt;</span>
+ <span class="nt">&lt;maintainer</span> <span class="na">type=</span><span class="s">&quot;project&quot;</span><span class="nt">&gt;</span>
+ <span class="nt">&lt;email&gt;</span>gnome@gentoo.org<span class="nt">&lt;/email&gt;</span>
+ <span class="nt">&lt;name&gt;</span>Gentoo GNOME Desktop<span class="nt">&lt;/name&gt;</span>
+ <span class="nt">&lt;/maintainer&gt;</span>
+ <span class="nt">&lt;use&gt;</span>
+ <span class="nt">&lt;flag</span> <span class="na">name=</span><span class="s">&quot;berkdb&quot;</span><span class="nt">&gt;&lt;pkg&gt;</span>sys-libs/db<span class="nt">&lt;/pkg&gt;</span> support needed to migrate old (pre-3.13 evolution versions) addressbook data<span class="nt">&lt;/flag&gt;</span>
+ <span class="nt">&lt;flag</span> <span class="na">name=</span><span class="s">&quot;gnome-online-accounts&quot;</span><span class="nt">&gt;</span>Enable <span class="nt">&lt;pkg&gt;</span>net-libs/gnome-online-accounts<span class="nt">&lt;/pkg&gt;</span> based Google authentication support<span class="nt">&lt;/flag&gt;</span>
+ <span class="nt">&lt;flag</span> <span class="na">name=</span><span class="s">&quot;oauth&quot;</span><span class="nt">&gt;</span>Enable internal OAuth2 authentication support for Google and Outlook.com.
+ If gnome-online-accounts is enabled and used, this is not necessary,
+ but both can be supported at the same time with different setup at runtime<span class="nt">&lt;/flag&gt;</span>
+ <span class="nt">&lt;flag</span> <span class="na">name=</span><span class="s">&quot;weather&quot;</span><span class="nt">&gt;</span>Enable optional weather calendar support<span class="nt">&lt;/flag&gt;</span>
+ <span class="nt">&lt;/use&gt;</span>
+<span class="nt">&lt;/pkgmetadata&gt;</span>
+</pre></div>
+</code></pre></td></tr></table>
+</div> <!-- class=content -->
+ </div>
+ </div>
+ </div>
+ </div>
+
+ <footer>
+ <div class="container">
+ <div class="row">
+ <div class="col-12 offset-md-2 col-md-7">
+ &nbsp;
+ </div>
+ <div class="col-12 col-md-3">
+ <h3 class="footerhead">Questions or comments?</h3>
+ Please feel free to <a href="https://www.gentoo.org/inside-gentoo/contact/">contact us</a>.
+ </div>
+ </div>
+ <div class="row">
+ <div class="col-2 col-sm-3 col-md-2">
+ <ul class="footerlinks three-icons">
+ <li><a href="https://twitter.com/gentoo" title="@Gentoo on Twitter"><span class="fa fa-twitter fa-fw"></span></a></li>
+ <li><a href="https://www.facebook.com/gentoo.org" title="Gentoo on Facebook"><span class="fa fa-facebook fa-fw"></span></a></li>
+ <li></li>
+ </ul>
+ </div>
+ <div class="col-10 col-sm-9 col-md-10">
+ <strong>&copy; 2001&ndash;2021 Gentoo Foundation, Inc.</strong><br>
+ <small>
+ Gentoo is a trademark of the Gentoo Foundation, Inc.
+ The contents of this document, unless otherwise expressly stated, are licensed under the
+ <a href="https://creativecommons.org/licenses/by-sa/4.0/" rel="license">CC-BY-SA-4.0</a> license.
+ The <a href="https://www.gentoo.org/inside-gentoo/foundation/name-logo-guidelines.html">Gentoo Name and Logo Usage Guidelines</a> apply.
+ </small>
+ </div>
+ </div>
+ </div>
+ </footer>
+
+ <script src="https://assets.gentoo.org/tyrian/v2/jquery-3.3.slim.js"></script>
+ <script src="https://assets.gentoo.org/tyrian/v2/popper.min.js"></script>
+ <script src="https://assets.gentoo.org/tyrian/v2/bootstrap.min.js"></script>
+</div> <!-- id=cgit -->
+</body>
+</html>