aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-12 15:20:45 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-12 15:21:05 +0200
commit7f7effd8d910828eb854a3865e8ba328f464af63 (patch)
tree47c5bd8afd26b2f35b280daa98f26fbbbe22a910 /gui-apps/corehunt
parentmedia-gfx/akira: Add new package. (diff)
downloadguru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.gz
guru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.bz2
guru-7f7effd8d910828eb854a3865e8ba328f464af63.zip
gui-*: bump cubocore to 4.2.0
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/corehunt')
-rw-r--r--gui-apps/corehunt/Manifest1
-rw-r--r--gui-apps/corehunt/corehunt-4.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-apps/corehunt/Manifest b/gui-apps/corehunt/Manifest
index 8679b9529..24b899fb8 100644
--- a/gui-apps/corehunt/Manifest
+++ b/gui-apps/corehunt/Manifest
@@ -1,3 +1,4 @@
DIST corehunt-4.0.0.tar.gz 49177 BLAKE2B f8904eba6af7854c882f26000e781295fa33d269637a5f66e54e0a152ccdbc51b952d4251eb50d6589edf8422d83fa4627cd4766ea1eeca89234c31f325fbaec SHA512 bbcb846039c3887e0f5b64a2e72c3cb5cabf31385d35870686c31e8a47d1ba7790c71941f5bdec422cfcc2f80b6dba47c1bac521c7365f68a546f5a2c990ebb2
DIST corehunt-4.1.0.tar.gz 49192 BLAKE2B e022d7125e9004c4beabe51feb884eb22d53c2beb2ca297b7cb1bd68629e6501d25e0860d6b554ee8290f8929ca13404ddbd4159a39c2f3dd811c7028b2b4c8e SHA512 d9428d0049d298921530e3f4ab2b389eb97b388ee1103e5643fb4f2f8c53191e2d8513ea2c7308c20b1e7ea8badfa055026b8266d228f5f5d7be5e369438c5fb
+DIST corehunt-4.2.0.tar.gz 51302 BLAKE2B dc45352a9affcb0ea2df974a9a6ae4219b9d1086793b8c33125fdd7e52f59452989f20c263b6ac863d695fd274987dad9aa6158b9a261f19c16066c12e7f9da8 SHA512 e2d45e317947888b14213581d653047d261dc06ac6888e3f3dcf005cd837959250938b6eb3c10027ef018fe9a6878ab4115be61932a1f02255a637a2afef01cb
DIST corehunt-4.2.0_alpha.tar.gz 50927 BLAKE2B fce9b6dc2e3d8ec19fa48ec53d60de2edfdf456c29b11570c72643f4b0d9c2cc91e94eb4eb87c89e5b2ab43c55cb296a7c0935f56e2785caa06807c42211a308 SHA512 82fcffd487a4f90811e0d6d7167dd2b70927a537adb99a4aa7031a5761d9cf26a191597e5aab776fc535c11cb4cbd6161ae4b0ed76d69671b9025307cad25d82
diff --git a/gui-apps/corehunt/corehunt-4.2.0.ebuild b/gui-apps/corehunt/corehunt-4.2.0.ebuild
new file mode 100644
index 000000000..9ecd013f9
--- /dev/null
+++ b/gui-apps/corehunt/corehunt-4.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="A file finder utility for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corehunt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"