aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-12 15:20:45 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-12 15:21:05 +0200
commit7f7effd8d910828eb854a3865e8ba328f464af63 (patch)
tree47c5bd8afd26b2f35b280daa98f26fbbbe22a910 /gui-apps/coreimage/coreimage-4.2.0.ebuild
parentmedia-gfx/akira: Add new package. (diff)
downloadguru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.gz
guru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.bz2
guru-7f7effd8d910828eb854a3865e8ba328f464af63.zip
gui-*: bump cubocore to 4.2.0
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/coreimage/coreimage-4.2.0.ebuild')
-rw-r--r--gui-apps/coreimage/coreimage-4.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gui-apps/coreimage/coreimage-4.2.0.ebuild b/gui-apps/coreimage/coreimage-4.2.0.ebuild
new file mode 100644
index 000000000..2b11baa2f
--- /dev/null
+++ b/gui-apps/coreimage/coreimage-4.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="An image viewer for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreimage"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+ gui-libs/libcsys
+"
+RDEPEND="
+ ${DEPEND}
+"