aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-05-09 15:42:18 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-05-09 15:43:17 +0200
commit803dde4216097ee1b2688d6816bfcfe61f85701a (patch)
treecfca8687a94a69d6f41a337a55132f62d377a10a /gui-apps/eww
parentgui-apps/swww: add 0.9.5, drop 0.9.1 (diff)
downloadguru-803dde4216097ee1b2688d6816bfcfe61f85701a.tar.gz
guru-803dde4216097ee1b2688d6816bfcfe61f85701a.tar.bz2
guru-803dde4216097ee1b2688d6816bfcfe61f85701a.zip
gui-apps/eww: move elog messages to pkg_postinst
Suggested-by: Mazunki Hoksaas <rolferen@gmail.com> Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'gui-apps/eww')
-rw-r--r--gui-apps/eww/eww-0.5.0-r4.ebuild3
-rw-r--r--gui-apps/eww/eww-0.6.0.ebuild3
-rw-r--r--gui-apps/eww/eww-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/gui-apps/eww/eww-0.5.0-r4.ebuild b/gui-apps/eww/eww-0.5.0-r4.ebuild
index c7cdf486b..25c33f18f 100644
--- a/gui-apps/eww/eww-0.5.0-r4.ebuild
+++ b/gui-apps/eww/eww-0.5.0-r4.ebuild
@@ -360,6 +360,9 @@ src_configure() {
src_install() {
dodoc README.md CHANGELOG.md
cargo_src_install --path crates/eww
+}
+
+pkg_postinst() {
elog "Eww wont run without a config file (usually in ~/.config/eww)."
elog "For example configs visit https://github.com/elkowar/eww#examples"
}
diff --git a/gui-apps/eww/eww-0.6.0.ebuild b/gui-apps/eww/eww-0.6.0.ebuild
index bbf4fc42a..bb3a1a0bf 100644
--- a/gui-apps/eww/eww-0.6.0.ebuild
+++ b/gui-apps/eww/eww-0.6.0.ebuild
@@ -446,6 +446,9 @@ src_install() {
dodoc README.md CHANGELOG.md
cargo_src_install --path crates/eww
+}
+
+pkg_postinst() {
elog "Eww wont run without a config file (usually in ~/.config/eww)."
elog "For example configs visit https://github.com/elkowar/eww#examples"
}
diff --git a/gui-apps/eww/eww-9999.ebuild b/gui-apps/eww/eww-9999.ebuild
index 99ce3c36f..595c7d76b 100644
--- a/gui-apps/eww/eww-9999.ebuild
+++ b/gui-apps/eww/eww-9999.ebuild
@@ -444,6 +444,9 @@ src_install() {
dodoc README.md CHANGELOG.md
cargo_src_install --path crates/eww
+}
+
+pkg_postinst() {
elog "Eww wont run without a config file (usually in ~/.config/eww)."
elog "For example configs visit https://github.com/elkowar/eww#examples"
}