aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Fox <flewkey@2a03.party>2021-08-28 02:17:51 +0000
committerRyan Fox <flewkey@2a03.party>2021-08-28 02:17:51 +0000
commit3d2ab42cf7e83513fc416e89a2c3f6734bb0ceb9 (patch)
treec783f0d354cc780419e78f379b333dd1639161a2 /gui-apps
parentgui-apps/foot-terminfo: Bump to 1.9.0 (diff)
downloadguru-3d2ab42cf7e83513fc416e89a2c3f6734bb0ceb9.tar.gz
guru-3d2ab42cf7e83513fc416e89a2c3f6734bb0ceb9.tar.bz2
guru-3d2ab42cf7e83513fc416e89a2c3f6734bb0ceb9.zip
gui-apps/foot: Bump to 1.9.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ryan Fox <flewkey@2a03.party>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.9.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index a92fa1587..ec90e2f07 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -3,3 +3,4 @@ DIST foot-1.7.2.tar.gz 392748 BLAKE2B effd72665c553fbf3687fdb17776b264a775311503
DIST foot-1.8.0.tar.gz 415924 BLAKE2B ec97a6b76f568770fd9011e2245aee9b96c8fc51fb11f022ce7cc8a40bae81d45172e5e435aeab4575a8123825481fe3537376ac700f7036ea4e7079a0844eac SHA512 eb0e0c1b29490f60b241259819bb2e7ab4b847e1d5a1fe70a31e893d8588e82f04f184d88a91e77222aba6fb9473f10e20461278535b6de4c2f3345440354583
DIST foot-1.8.1.tar.gz 428685 BLAKE2B 10ad1adf67e3e7171cc60db3dd90a8bdb676f3df61c518f33150c893ee0a552e28b9647cbae03861b85bf4c8501785eaf8a984726a814da2866a06d1a71b3891 SHA512 62a4cc018e49e270b8d806ea5b5c17965428a0f943b814608c25eb674db6130bfedae2431ac0c61f9c8de6bd227859cedb032f0f573a1e0885938d11efbda4e4
DIST foot-1.8.2.tar.gz 432906 BLAKE2B 25dfa24df5e95a29b0cc19c0d67cd3025cee3cad03069feca748e580dc1a42e1e2c4eebee0c3549edf522d12da5bc80fd5947a0a7f28658e3f207b76562c60a2 SHA512 8442761f20d8d5e315c2cbf75c40a6fd8e449f6ce515a1a3aac2106b4c9d7c8257ed96b5e1808eb0e9fda448a2a1bbb6b55cfb8d7abd6acb184cabcdc43d5fa5
+DIST foot-1.9.0.tar.gz 446060 BLAKE2B 2930f155509d2614b1eb0027648e55a97bba3d8ff59c8ea4a181db0e556e3f94b924ccd812653853793c885c6594745de991073f6ec7eaf2438927a033ba6515 SHA512 ffdefd0d42c1a2092af9d6aaf6cd1d33f017424177a3144d317d2bbc502afa1373db9bb5d0042847ff704c76667198e16e5ab861907db2451941517109f2db62
diff --git a/gui-apps/foot/foot-1.9.0.ebuild b/gui-apps/foot/foot-1.9.0.ebuild
new file mode 100644
index 000000000..dba0d9b5c
--- /dev/null
+++ b/gui-apps/foot/foot-1.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/foot.git"
+fi
+
+DESCRIPTION="A fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+LICENSE="MIT"
+SLOT="0"
+IUSE="ime +grapheme-clustering"
+
+DEPEND="
+ dev-libs/libutf8proc
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+"
+RDEPEND="
+ ${DEPEND}
+ gui-apps/foot-terminfo
+"
+BDEPEND="
+ app-text/scdoc
+ dev-libs/tllist
+ dev-libs/wayland-protocols
+ sys-libs/ncurses
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ime)
+ $(meson_feature grapheme-clustering)
+ "-Dterminfo=disabled"
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
+}