aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Fox <flewkey@2a03.party>2021-11-21 01:39:03 -0800
committerRyan Fox <flewkey@2a03.party>2021-11-21 01:45:27 -0800
commit51e841091a169a22c5d5f3d76d10fb8489d91711 (patch)
tree038d42b8bedd8e19f648898b848226da7ef8d3a9 /gui-apps
parentnet-misc/wsdd: version bump to 0.7.0, add Python 3.10 support (diff)
downloadguru-51e841091a169a22c5d5f3d76d10fb8489d91711.tar.gz
guru-51e841091a169a22c5d5f3d76d10fb8489d91711.tar.bz2
guru-51e841091a169a22c5d5f3d76d10fb8489d91711.zip
gui-apps/foot-terminfo: Prevent package collision
Versions of sys-libs/ncurses since 2021-07-31 have added a version of the foot terminfo with less features. Due to issues with installing terminfo in a nonstandard location, the current recommendation is to use the ncurses version if it is installed. This adds a blocking dependency for recent versions of sys-libs/ncurses to prevent the package conflict. Closes: https://bugs.gentoo.org/825434 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ryan Fox <flewkey@2a03.party>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/foot-terminfo/foot-terminfo-1.10.0.ebuild4
-rw-r--r--gui-apps/foot-terminfo/foot-terminfo-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/gui-apps/foot-terminfo/foot-terminfo-1.10.0.ebuild b/gui-apps/foot-terminfo/foot-terminfo-1.10.0.ebuild
index d72edcdf7..7a520230f 100644
--- a/gui-apps/foot-terminfo/foot-terminfo-1.10.0.ebuild
+++ b/gui-apps/foot-terminfo/foot-terminfo-1.10.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> foot-${PV}.tar.gz"
@@ -18,7 +18,7 @@ LICENSE="MIT"
SLOT="0"
DEPEND=""
-RDEPEND="${DEPEND}"
+RDEPEND="<sys-libs/ncurses-6.3"
BDEPEND="sys-libs/ncurses"
src_prepare() {
diff --git a/gui-apps/foot-terminfo/foot-terminfo-9999.ebuild b/gui-apps/foot-terminfo/foot-terminfo-9999.ebuild
index d72edcdf7..7a520230f 100644
--- a/gui-apps/foot-terminfo/foot-terminfo-9999.ebuild
+++ b/gui-apps/foot-terminfo/foot-terminfo-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> foot-${PV}.tar.gz"
@@ -18,7 +18,7 @@ LICENSE="MIT"
SLOT="0"
DEPEND=""
-RDEPEND="${DEPEND}"
+RDEPEND="<sys-libs/ncurses-6.3"
BDEPEND="sys-libs/ncurses"
src_prepare() {