aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-04-25 12:50:06 +0200
committertastytea <gentoo@tastytea.de>2024-04-25 12:50:06 +0200
commit548fa3a56d291b70d3bd081a85bec36240f278cf (patch)
tree5ded29892051e7fe097b518e7f2701e72f4e6a0d /gui-apps
parentdev-python/importlib-resources: treeclean, moved to ::gentoo (diff)
downloadguru-548fa3a56d291b70d3bd081a85bec36240f278cf.tar.gz
guru-548fa3a56d291b70d3bd081a85bec36240f278cf.tar.bz2
guru-548fa3a56d291b70d3bd081a85bec36240f278cf.zip
gui-apps/intiface-central-bin: add 2.5.7
Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/intiface-central-bin/Manifest1
-rw-r--r--gui-apps/intiface-central-bin/intiface-central-bin-2.5.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/gui-apps/intiface-central-bin/Manifest b/gui-apps/intiface-central-bin/Manifest
index 868d05946..a488a4257 100644
--- a/gui-apps/intiface-central-bin/Manifest
+++ b/gui-apps/intiface-central-bin/Manifest
@@ -1,2 +1,3 @@
DIST intiface-central-v2.5.3-linux-ubuntu-22.04-x64.zip 19222068 BLAKE2B 05a2e33c5aeae2a839fcdbd5bc2fc5b58c8af0d985b962a158fd412bfbe60a5cd0cb350e62f6b76473a8ca6349579b610fe1702a2c8077bb8e54bd76e21a34ae SHA512 904bd8d24a8982aed7bfd510022081d077897e3900859556ff0a93b3c6f87757f20c84a65cb398595656f6f5ebc54655b7fd85b119491f5ddb0d962c8c9a470b
DIST intiface-central-v2.5.5-linux-ubuntu-22.04-x64.zip 39887250 BLAKE2B d854274adcac9d06ee412142908d77f6332f12178bfb45cd7895cba014d2227ae2a56220d553af2381029c9aa2c6c93634a9872fdfcc9aa6ec69def0fdcd0710 SHA512 81b4b604c417df1d6d5b4246207c2847eb861543e3722c79c72781a57aa7f1ffdbdbfa079741b9cb42ee98b33f7e36a0c6df7963d1b0eb9c52d0eb9ef6c49086
+DIST intiface-central-v2.5.7-linux-ubuntu-22.04-x64.zip 19978864 BLAKE2B 0e22f90eaf464fae0463f31a6a1537154956c44e04a91514aca2f097c4f2494d802b1e40e762b2e7f639efaf142b9fed56384fe5d1e167afba39132678554049 SHA512 be855842b3150e7e9f972502dc2711051528305419c135c525ac3d2d5b5002e1c923d91fee9d533e170f05d29bc0047e2772b8e10ba8373c10eb7d4ce034e4eb
diff --git a/gui-apps/intiface-central-bin/intiface-central-bin-2.5.7.ebuild b/gui-apps/intiface-central-bin/intiface-central-bin-2.5.7.ebuild
new file mode 100644
index 000000000..23ba73ce7
--- /dev/null
+++ b/gui-apps/intiface-central-bin/intiface-central-bin-2.5.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Buttplug frontend application"
+HOMEPAGE="https://github.com/intiface/intiface-central"
+SRC_URI="https://github.com/intiface/intiface-central/releases/download/v${PV}/intiface-central-v${PV}-linux-ubuntu-22.04-x64.zip"
+S="${WORKDIR}/${PN/-bin/}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ media-gfx/graphite2
+ sys-apps/dbus
+ sys-apps/systemd-utils
+ x11-libs/gtk+:3[X]
+ dev-libs/openssl:0/3
+"
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="
+ opt/${PN}/lib/*.so
+ opt/${PN}/intiface_central
+"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r .
+ fperms +x /opt/${PN}/intiface_central
+
+ cat << EOF > intiface_central
+#!/bin/sh
+cd /opt/${PN}
+./intiface_central "\${@}"
+EOF
+ dobin intiface_central
+
+ newicon --size 512 \
+ data/flutter_assets/assets/icons/intiface_central_icon.png ${PN}.png
+
+ make_desktop_entry intiface_central "Intiface Central" ${PN} "Utility"
+}