aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo H. Neumann <leonardohn@null.net>2021-07-27 00:43:00 -0300
committerLeonardo H. Neumann <leonardohn@null.net>2021-07-27 00:48:29 -0300
commit5e71bab4ab8d4bbc68caef502829843baf97e0d0 (patch)
tree57cefe4dec7e341a373fc516a4c247787f3b47bc /gui-apps
parentkde-apps/alligator: add 21.07, drop 21.05 (diff)
downloadguru-5e71bab4ab8d4bbc68caef502829843baf97e0d0.tar.gz
guru-5e71bab4ab8d4bbc68caef502829843baf97e0d0.tar.bz2
guru-5e71bab4ab8d4bbc68caef502829843baf97e0d0.zip
gui-apps/yambar: new package (1.6.2)
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Leonardo H. Neumann <leonardohn@null.net>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/yambar/Manifest1
-rw-r--r--gui-apps/yambar/metadata.xml18
-rw-r--r--gui-apps/yambar/yambar-1.6.2.ebuild65
-rw-r--r--gui-apps/yambar/yambar-9999.ebuild65
4 files changed, 149 insertions, 0 deletions
diff --git a/gui-apps/yambar/Manifest b/gui-apps/yambar/Manifest
new file mode 100644
index 000000000..ef709545a
--- /dev/null
+++ b/gui-apps/yambar/Manifest
@@ -0,0 +1 @@
+DIST yambar-1.6.2.tar.gz 135455 BLAKE2B 71d5b584bf04a7212ac84d8e0d8cb71c1abd7c7548c5ec998aff480d76afbd09825b059fe642edd4dd2537af6a5b811bd333a45bfa53f6a3a814a2be95eb58b4 SHA512 64a5e983be6dc99feb2f39d06fe265163c3b8f3f23f33a58c386891b63a9c915816cbde22d031473e700e839522c86c53b06f0cce1a57ebdab8ed6aeebe627e1
diff --git a/gui-apps/yambar/metadata.xml b/gui-apps/yambar/metadata.xml
new file mode 100644
index 000000000..f30b9742f
--- /dev/null
+++ b/gui-apps/yambar/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>leonardohn@null.net</email>
+ <name>Leonardo H. Neumann</name>
+ </maintainer>
+ <longdescription lang="en">
+ Simplistic and highly configurable status panel for X and Wayland
+ </longdescription>
+ <use>
+ <flag name="lto">Build with Link Time Optimization (LTO)</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://codeberg.org/dnkl/yambar/issues</bugs-to>
+ <changelog>https://codeberg.org/dnkl/yambar/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/yambar/yambar-1.6.2.ebuild b/gui-apps/yambar/yambar-1.6.2.ebuild
new file mode 100644
index 000000000..1f4199e17
--- /dev/null
+++ b/gui-apps/yambar/yambar-1.6.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/${PN}.git"
+fi
+
+DESCRIPTION="Simplistic and highly configurable status panel for X and Wayland"
+HOMEPAGE="https://codeberg.org/dnkl/yambar"
+LICENSE="MIT"
+SLOT="0"
+IUSE="lto wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+RDEPEND="
+ >=media-libs/fcft-2.4.0
+ dev-libs/json-c
+ dev-libs/libyaml
+ media-libs/alsa-lib
+ media-libs/libmpdclient
+ virtual/libudev:=
+ x11-libs/pixman
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libxcb:0=[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/scdoc
+ >=dev-libs/tllist-1.0.1
+ >=dev-util/meson-0.53.0
+ virtual/pkgconfig
+ wayland? (
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland backend-wayland)
+ $(meson_feature X backend-x11)
+ $(meson_use lto b_lto)
+ -Dwerror=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ rm -rf "${D}/usr/share/doc/${PN}"
+}
diff --git a/gui-apps/yambar/yambar-9999.ebuild b/gui-apps/yambar/yambar-9999.ebuild
new file mode 100644
index 000000000..1f4199e17
--- /dev/null
+++ b/gui-apps/yambar/yambar-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/${PN}.git"
+fi
+
+DESCRIPTION="Simplistic and highly configurable status panel for X and Wayland"
+HOMEPAGE="https://codeberg.org/dnkl/yambar"
+LICENSE="MIT"
+SLOT="0"
+IUSE="lto wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+RDEPEND="
+ >=media-libs/fcft-2.4.0
+ dev-libs/json-c
+ dev-libs/libyaml
+ media-libs/alsa-lib
+ media-libs/libmpdclient
+ virtual/libudev:=
+ x11-libs/pixman
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libxcb:0=[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/scdoc
+ >=dev-libs/tllist-1.0.1
+ >=dev-util/meson-0.53.0
+ virtual/pkgconfig
+ wayland? (
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland backend-wayland)
+ $(meson_feature X backend-x11)
+ $(meson_use lto b_lto)
+ -Dwerror=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ rm -rf "${D}/usr/share/doc/${PN}"
+}