aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-02 08:35:31 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-02 08:35:31 +0500
commit68f5230b9d40ec51982cb87dbb7885843dc14fe3 (patch)
tree5316a329d5074550ab7507e950e628c5413b65ce /gui-apps
parentwww-apps/invidious: add 2023.04.01, drop 2023.01.26 (diff)
downloadguru-68f5230b9d40ec51982cb87dbb7885843dc14fe3.tar.gz
guru-68f5230b9d40ec51982cb87dbb7885843dc14fe3.tar.bz2
guru-68f5230b9d40ec51982cb87dbb7885843dc14fe3.zip
gui-apps/meteo-qt: new package, add 3.3
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/meteo-qt/Manifest1
-rw-r--r--gui-apps/meteo-qt/metadata.xml11
-rw-r--r--gui-apps/meteo-qt/meteo-qt-3.3.ebuild40
3 files changed, 52 insertions, 0 deletions
diff --git a/gui-apps/meteo-qt/Manifest b/gui-apps/meteo-qt/Manifest
new file mode 100644
index 000000000..7922ae828
--- /dev/null
+++ b/gui-apps/meteo-qt/Manifest
@@ -0,0 +1 @@
+DIST meteo-qt-3.3.gh.tar.gz 931450 BLAKE2B 0f8128ba768510b278862e2dbe33267cb339cb6fb6299e6448f49a6d5efaf98db045bd07833695e2eea936ce78bece4bc62bb62322a1df43767438e72c26dc86 SHA512 e52d05b98b99ecc01b9d584cf15db495f5c1eaa6e3ac1f429542d9d43e3890b03d93e3c7a55059821a32ea614cce7bb104b9353c59da04f164b561c920cca415
diff --git a/gui-apps/meteo-qt/metadata.xml b/gui-apps/meteo-qt/metadata.xml
new file mode 100644
index 000000000..71b2eabaa
--- /dev/null
+++ b/gui-apps/meteo-qt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dglent/meteo-qt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/meteo-qt/meteo-qt-3.3.ebuild b/gui-apps/meteo-qt/meteo-qt-3.3.ebuild
new file mode 100644
index 000000000..7c916f7f2
--- /dev/null
+++ b/gui-apps/meteo-qt/meteo-qt-3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 qmake-utils xdg
+
+DESCRIPTION="A system tray application for the weather status"
+HOMEPAGE="https://github.com/dglent/meteo-qt"
+SRC_URI="https://github.com/dglent/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ dev-python/PyQt5
+ dev-qt/linguist-tools
+"
+
+src_compile() {
+ local -x PATH="$(qt5_get_bindir):${PATH}"
+ distutils-r1_src_compile
+}
+
+python_install() {
+ mv "${BUILD_DIR}/install$(python_get_sitedir)/usr" "${ED}" || die
+ rm -r "${ED}/usr/share/doc" || die
+
+ distutils-r1_python_install
+}