aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-04-25 20:22:05 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-04-25 20:24:50 +0200
commit769b74da561e723446d8e976a0ff9d222fd2d98a (patch)
tree4b53b222181053d47d07631ebe08871709e11c51 /gui-apps
parentapp-editors/lapce: add 0.4.0 (diff)
downloadguru-769b74da561e723446d8e976a0ff9d222fd2d98a.tar.gz
guru-769b74da561e723446d8e976a0ff9d222fd2d98a.tar.bz2
guru-769b74da561e723446d8e976a0ff9d222fd2d98a.zip
gui-apps/nwg-shell-config: add 0.5.35
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell-config/.pkgbump-pv1
-rw-r--r--gui-apps/nwg-shell-config/Manifest1
-rw-r--r--gui-apps/nwg-shell-config/nwg-shell-config-0.5.35.ebuild41
3 files changed, 43 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell-config/.pkgbump-pv b/gui-apps/nwg-shell-config/.pkgbump-pv
new file mode 100644
index 000000000..0defa4dc0
--- /dev/null
+++ b/gui-apps/nwg-shell-config/.pkgbump-pv
@@ -0,0 +1 @@
+0.5.35
diff --git a/gui-apps/nwg-shell-config/Manifest b/gui-apps/nwg-shell-config/Manifest
index 4488cd4c7..528c61bda 100644
--- a/gui-apps/nwg-shell-config/Manifest
+++ b/gui-apps/nwg-shell-config/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-config-0.5.33.tar.gz 114758 BLAKE2B 792e9ed84361369bfb9617f267d68573f7170b2410744563d7d2fe2c8d527ca0eccc4172e9c421ed8c148bfcd1c868530f362740dd57e2cdd2df5aa801906a81 SHA512 8b79f10aa99d774722d49bb6e633e5e4e024f5dc55efdd0362220f85ab267ebaea8b016c051f92c6bbf0a74f2503d03a7ce5548a0e84ebab0dbc293a5f01c679
DIST nwg-shell-config-0.5.34.tar.gz 114850 BLAKE2B e073494bc3f4375e4c3545777965953ff6504130981745948939483a29b42a5e676bdc51dbef27f1f99f0e94f1b8a465da570b7c68ea4ac81c09e04ef5ddaa5d SHA512 a140756ad0f7ff4da98f212ffb5aab656e6caf2d795efccddad3544e67737a90f15e02b6040c3b2e4324f7adbde38457a24eadcece3df55b5a614cd37cc636c8
+DIST nwg-shell-config-0.5.35.tar.gz 117479 BLAKE2B fe6f733687252c999eb84eaa868889fac350037841a3e7d6efd153c335a969497a3a8a49782c8b54f715c7b416eb308a9d74e96110c5900b99806c3cffb5a46f SHA512 04ad32bdaffbb601c0fd18379b92c7e7b1903880049339154cbc5507e1dbf78540f24265fcc70f24a78df915ee3dd3afcccc6135f8e4033206ccf026ffb3f863
diff --git a/gui-apps/nwg-shell-config/nwg-shell-config-0.5.35.ebuild b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.35.ebuild
new file mode 100644
index 000000000..18bb5419f
--- /dev/null
+++ b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.35.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="nwg-shell configuration utility"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell-config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/nwg-shell
+ sci-geosciences/geopy
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-shell-config.desktop
+ doicon nwg-shell-config.svg
+ doicon nwg-shell-update.svg
+ doicon nwg-shell-translate.svg
+ doicon nwg-update-noupdate.svg
+ doicon nwg-update-available.svg
+ doicon nwg-update-checking.svg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}