aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2022-04-08 07:52:47 -0700
committerYuan Liao <liaoyuan@gmail.com>2022-04-08 07:52:47 -0700
commitd2ed8ba6f5c90d4a4e8f87237a60d5fafc00effa (patch)
treee2133967163e6ac0b10835a24c5804562ed5eab6 /gui-libs
parentapp-containers/netavark: new package (diff)
downloadguru-d2ed8ba6f5c90d4a4e8f87237a60d5fafc00effa.tar.gz
guru-d2ed8ba6f5c90d4a4e8f87237a60d5fafc00effa.tar.bz2
guru-d2ed8ba6f5c90d4a4e8f87237a60d5fafc00effa.zip
gui-libs/text-engine: Add 0.1.1
Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/text-engine/Manifest1
-rw-r--r--gui-libs/text-engine/text-engine-0.1.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/text-engine/Manifest b/gui-libs/text-engine/Manifest
index d43363127..5ea7b8933 100644
--- a/gui-libs/text-engine/Manifest
+++ b/gui-libs/text-engine/Manifest
@@ -1 +1,2 @@
DIST text-engine-0.1.0.tar.gz 15728 BLAKE2B 41a5b4bb0347eca29268cf089a7ea127a0a467fa123384bc1d92cbb215ca98f9963742ba5f93972d163c7f6708ac428762a92023d98ad130b56657b6eccb7956 SHA512 36be3e913187dfbba96945891a64cb2b3efde8324cdb3457a64c2fdfd19e2c1289d48a92ca60c957c52e18a6cabbcc13f178c34687f183f60557e41db5c36418
+DIST text-engine-0.1.1.tar.gz 16568 BLAKE2B 71c6766592aa143413721c36d9282624e4bcd1f8594b5a9c1dde24f30704da690ebad8ae483fb04490ec383f6434c211f0c21c37661ba647c97bcae6241231e6 SHA512 8f3d4e7964d7256c1386200aa4338d8d6ff35e4578e50381b1fcbdc1a232f4da28c74bc8bfe66a5507888197cbf430cac03730d8624381bd5a2b023eecc73736
diff --git a/gui-libs/text-engine/text-engine-0.1.1.ebuild b/gui-libs/text-engine/text-engine-0.1.1.ebuild
new file mode 100644
index 000000000..3d0af284c
--- /dev/null
+++ b/gui-libs/text-engine/text-engine-0.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mjakeman/text-engine.git"
+else
+ SRC_URI="https://github.com/mjakeman/text-engine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A lightweight rich-text framework for GTK 4"
+HOMEPAGE="https://github.com/mjakeman/text-engine"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ gui-libs/gtk:4
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/json-glib
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-libs/pango
+"
+
+src_prepare() {
+ default
+ sed -i -e "/subdir('demo')/d" meson.build ||
+ die "Failed to modify meson.build to exclude the demo program"
+}