aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-30 23:18:30 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-30 23:19:38 +0200
commitdf1e257df34f747a64701354a4e33d9fc35e56b2 (patch)
tree0e9e09341311f4c6a9eed6b4b9367db23f966b5c /media-libs
parentmedia-libs/libbpg: Add missing dependencies. (diff)
downloadguru-df1e257df34f747a64701354a4e33d9fc35e56b2.tar.gz
guru-df1e257df34f747a64701354a4e33d9fc35e56b2.tar.bz2
guru-df1e257df34f747a64701354a4e33d9fc35e56b2.zip
media-libs/libbpg: Add -lnuma to X265_LIBS instead of to LIBS.
X265_LIBS is only used in bpgenc binary, LIBS in bpgenc bpgdec and bpgview. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libbpg/libbpg-0.9.8.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/libbpg/libbpg-0.9.8.ebuild b/media-libs/libbpg/libbpg-0.9.8.ebuild
index 265654470..07640fa3d 100644
--- a/media-libs/libbpg/libbpg-0.9.8.ebuild
+++ b/media-libs/libbpg/libbpg-0.9.8.ebuild
@@ -47,6 +47,8 @@ Version: ${PV}
Libs: "-L\${libdir}" -lbpg
Cflags: "-I\${includedir}"
EOF
+
+ sed -Ei 's/^(X265_LIBS:=.+\.a)$/\1 -lnuma/' Makefile || die
}
src_compile() {
@@ -56,8 +58,7 @@ src_compile() {
$(usex jctvc USE_JCTVC=y '') \
$(usex emcc USE_EMCC=y '') \
CXX="$(tc-getCXX)" \
- CC="$(tc-getCC)" \
- LIBS="-lrt -lm -lpthread -lnuma"
+ CC="$(tc-getCC)"
}
src_install() {