aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-10 22:23:34 +1300
committerTheo Anderson <telans@posteo.de>2020-12-10 22:23:44 +1300
commit3bf52338eb9d9d47d3290a2f5b8af51401782860 (patch)
tree69c916fb53292a46830a6c0659e682b03daf8b11 /media-sound
parentsys-fs/dwarfs: fixed bug with installation of libraries (diff)
downloadguru-3bf52338eb9d9d47d3290a2f5b8af51401782860.tar.gz
guru-3bf52338eb9d9d47d3290a2f5b8af51401782860.tar.bz2
guru-3bf52338eb9d9d47d3290a2f5b8af51401782860.zip
media-sound/add64: bump to 3.9.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/add64/Manifest1
-rw-r--r--media-sound/add64/add64-3.8.0.ebuild14
-rw-r--r--media-sound/add64/add64-3.9.3.ebuild40
3 files changed, 49 insertions, 6 deletions
diff --git a/media-sound/add64/Manifest b/media-sound/add64/Manifest
index daf345f3b..c9bfb9044 100644
--- a/media-sound/add64/Manifest
+++ b/media-sound/add64/Manifest
@@ -1 +1,2 @@
DIST Add64-3.8.0.tar.bz2 76729 BLAKE2B ddc13205617d78a9a79748cbb1a600efee87ed336e606e40fd079f5b413799ab25a252357f1578db1913f7dba1d205c255ac38dbb358df49086da33b8882da78 SHA512 4d7c1761f781ee70731944366170f8de04ce83c5ff396c412226d7a008a51b43abf4a33ba33b7720a67f714bb0b6c78d4b4faed15d721297066c9d997543dd33
+DIST Add64-3.9.3.tar.bz2 87299 BLAKE2B c0af3024b903c460b6f50eb7c963cd7f75a6329b6efbfe66b65ce88b3fc82670f10a355bc6f4b4cd3e93e9033c1ec831d7f92649d55098df2dc2520a13662714 SHA512 c637ed12b733d8b2f6e705b4ae38d67a4dd5f0ec4c8fd3c58c417dedb6cfeb3c0748159cfbe45655288702d359be4895ef85feb24ac6e54babccaa314ffe1851
diff --git a/media-sound/add64/add64-3.8.0.ebuild b/media-sound/add64/add64-3.8.0.ebuild
index d9f822dad..99d7dd3f6 100644
--- a/media-sound/add64/add64-3.8.0.ebuild
+++ b/media-sound/add64/add64-3.8.0.ebuild
@@ -7,18 +7,21 @@ inherit qmake-utils
DESCRIPTION="Add64 is a realtime additive/subtractive-synthesis softsynth"
HOMEPAGE="https://sourceforge.net/projects/add64 http://linuxsynths.com/Add64PatchesDemos/add64.html"
+SRC_URI="mirror://sourceforge/project/add64/Add64-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+presets"
-LICENSE="GPL-3"
-SRC_URI="mirror://sourceforge/project/add64/Add64-${PV}.tar.bz2"
-
-RDEPEND="dev-qt/qtcore:5
+RDEPEND="
+ dev-qt/qtcore:5
+ media-libs/alsa-lib
virtual/opengl
virtual/jack
- media-libs/alsa-lib"
+"
DEPEND="${RDEPEND}"
+
S="${WORKDIR}/Add64-${PV}/"
src_configure(){
@@ -34,5 +37,4 @@ src_install(){
insinto /usr/share/add64/Add64Presets
doins "${S}"/Add64Presets/* || die "can't install presets"
fi
- elog "You may also download additional patches from http://linuxsynths.com/Add64PatchesDemos/add64.html"
}
diff --git a/media-sound/add64/add64-3.9.3.ebuild b/media-sound/add64/add64-3.9.3.ebuild
new file mode 100644
index 000000000..dac0d5dc6
--- /dev/null
+++ b/media-sound/add64/add64-3.9.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Add64 is a realtime additive/subtractive-synthesis softsynth"
+HOMEPAGE="
+ https://sourceforge.net/projects/add64
+ http://linuxsynths.com/Add64PatchesDemos/add64.html
+"
+SRC_URI="mirror://sourceforge/project/add64/Add64-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ media-libs/alsa-lib
+ virtual/opengl
+ virtual/jack
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/Add64-${PV}/"
+
+src_compile() {
+ eqmake5
+ default
+}
+
+src_install() {
+ dobin "${S}/Add64"
+ insinto /usr/share/add64/
+ doins "${S}/Add64-MIDIconfig"
+ insinto /usr/share/add64/Add64Presets
+ doins "${S}"/Add64Presets/*
+}