aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2023-11-28 01:51:54 +0100
committerAdel KARA SLIMANE <adel.ks@zegrapher.com>2023-11-28 01:51:54 +0100
commit74696e84f47118d6e7f63cc4beb7cd588b8551c2 (patch)
treed4c1e81225b212f477b97ec48f7842814f696e3d /media-video/obs-multi-rtmp
parentgames-util/mangohud: replace patches with sed calls (diff)
downloadguru-74696e84f47118d6e7f63cc4beb7cd588b8551c2.tar.gz
guru-74696e84f47118d6e7f63cc4beb7cd588b8551c2.tar.bz2
guru-74696e84f47118d6e7f63cc4beb7cd588b8551c2.zip
media-video/obs-multi-rtmp: new package, add 0.5.0.4, 9999
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com>
Diffstat (limited to 'media-video/obs-multi-rtmp')
-rw-r--r--media-video/obs-multi-rtmp/Manifest1
-rw-r--r--media-video/obs-multi-rtmp/metadata.xml16
-rw-r--r--media-video/obs-multi-rtmp/obs-multi-rtmp-0.5.0.4.ebuild44
-rw-r--r--media-video/obs-multi-rtmp/obs-multi-rtmp-9999.ebuild44
4 files changed, 105 insertions, 0 deletions
diff --git a/media-video/obs-multi-rtmp/Manifest b/media-video/obs-multi-rtmp/Manifest
new file mode 100644
index 000000000..20f0cf0a6
--- /dev/null
+++ b/media-video/obs-multi-rtmp/Manifest
@@ -0,0 +1 @@
+DIST obs-multi-rtmp-0.5.0.4.tar.gz 399130 BLAKE2B ee35f2dbe61f5adce9c987358fd1d8ffefc35a019b47ccbf86f4dd35bcf7296e4fb5c4f3b9d96af29005d454feb6d8d84314bc2589b89050781b5139d61b5d08 SHA512 2efa9a9e4915fe211263dd7ed43fe00c31fe2740555c2b366d90acc8be4ea6c9e35518500520358b105bedf7e32be36dcbeafc05e171e360e8cc2867f1cb80f1
diff --git a/media-video/obs-multi-rtmp/metadata.xml b/media-video/obs-multi-rtmp/metadata.xml
new file mode 100644
index 000000000..5934f0e0e
--- /dev/null
+++ b/media-video/obs-multi-rtmp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>adel.ks@zegrapher.com</email>
+ <name>Adel KARA SLIMANE</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sorayuki/obs-multi-rtmp</remote-id>
+ <bugs-to>https://github.com/sorayuki/obs-multi-rtmp/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name="qt">Use Qt functionality.</flag>
+ <flag name="obs-frontend-api">Use obs-frontend-api for UI functionality.</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/obs-multi-rtmp/obs-multi-rtmp-0.5.0.4.ebuild b/media-video/obs-multi-rtmp/obs-multi-rtmp-0.5.0.4.ebuild
new file mode 100644
index 000000000..670929404
--- /dev/null
+++ b/media-video/obs-multi-rtmp/obs-multi-rtmp-0.5.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="OBS Simulcast support plugin"
+HOMEPAGE="https://github.com/orayuki/obs-multi-rtmp"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sorayuki/obs-multi-rtmp.git"
+else
+ SRC_URI="https://github.com/sorayuki/obs-multi-rtmp/archive/refs/tags/$PV.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+obs-frontend-api +qt"
+RDEPEND="
+ media-video/obs-studio
+"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DENABLE_FRONTEND_API=$(usex obs-frontend-api ON OFF)
+ -DENABLE_QT=$(usex qt ON OFF)
+ )
+
+ # code base is not clean
+ # opened bug https://github.com/sorayuki/obs-multi-rtmp/issues/378
+ append-cppflags -Wno-error=shadow -Wno-error=conversion -Wno-error=float-conversion -Wno-error=sign-compare
+
+ cmake_src_configure
+}
diff --git a/media-video/obs-multi-rtmp/obs-multi-rtmp-9999.ebuild b/media-video/obs-multi-rtmp/obs-multi-rtmp-9999.ebuild
new file mode 100644
index 000000000..8e6e068ab
--- /dev/null
+++ b/media-video/obs-multi-rtmp/obs-multi-rtmp-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="OBS Simulcast support plugin"
+HOMEPAGE="https://github.com/orayuki/obs-multi-rtmp"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sorayuki/obs-multi-rtmp.git"
+else
+ SRC_URI="https://github.com/orayuki/obs-multi-rtmp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+obs-frontend-api +qt"
+RDEPEND="
+ media-video/obs-studio
+"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DENABLE_FRONTEND_API=$(usex obs-frontend-api ON OFF)
+ -DENABLE_QT=$(usex qt ON OFF)
+ )
+
+ # code base is not clean
+ # opened bug https://github.com/sorayuki/obs-multi-rtmp/issues/378
+ append-cppflags -Wno-error=shadow -Wno-error=conversion -Wno-error=float-conversion -Wno-error=sign-compare
+
+ cmake_src_configure
+}