aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-04-06 23:37:36 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-04-06 23:37:36 +0200
commit66b2e16ccbd1efb1eb55965ef8853082dc1d6c47 (patch)
tree098092135187e063fbe9abe38a02a9171456e6a8 /media-video
parentdev-python/simplemma: bump version, rm old ebuild (diff)
downloadguru-66b2e16ccbd1efb1eb55965ef8853082dc1d6c47.tar.gz
guru-66b2e16ccbd1efb1eb55965ef8853082dc1d6c47.tar.bz2
guru-66b2e16ccbd1efb1eb55965ef8853082dc1d6c47.zip
media-video/mpv-mpris: add 0.7.1
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv-mpris/Manifest1
-rw-r--r--media-video/mpv-mpris/mpv-mpris-0.7.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-video/mpv-mpris/Manifest b/media-video/mpv-mpris/Manifest
index cee0cf89e..afd0ebfa1 100644
--- a/media-video/mpv-mpris/Manifest
+++ b/media-video/mpv-mpris/Manifest
@@ -1,2 +1,3 @@
DIST mpv-mpris-0.6.tar.gz 8910 BLAKE2B 44888f9a0945bf850ba48a4b2a5b2d03325e05b17111a6184c3540eaf15745c7bb18006b03dd018599e017837c005bf10dafc910b3e031e440a511a5496d6ab4 SHA512 da92e4cf6541f0f18fc1c779ab87eef914e6e76a94bfe1259b323953a11654b228d02c4d352ea0c588308bedc8aa807bdaa41023917629a90d50269f454e256d
+DIST mpv-mpris-0.7.1.tar.gz 13432 BLAKE2B 884204c2186bc3b52378113dde87e58578b3811ec1a40576eb30e779fe3a3575ad9db802a51434e9fc3d22785db6036f898c76acab61780fac4b35276a17524f SHA512 7e928bbbf85b5c8e1e92ce51e65986ef7a7fe27a1e382b0148cdd70e22e5320be37a573c6206b3a1ab05119d9d24b861fd45081a008111f1da37673aa3896f23
DIST mpv-mpris-0.7.tar.gz 12982 BLAKE2B db919cdad6528519211725694f63871e371a33a331c46eebb202fa87d452d1cf30cecf3d4c2b26cb187cfa2c4cdd53411b88e6e7855510ffbaeef28ab3eb8346 SHA512 b370c9550622302cfdd07c21ae2f03a4e66e80da02e8f38c68d447ef273ae582ad6d918e207a9fb8c917a851163c6aadc08d3d68ad8e70ec85b37732c0cac96f
diff --git a/media-video/mpv-mpris/mpv-mpris-0.7.1.ebuild b/media-video/mpv-mpris/mpv-mpris-0.7.1.ebuild
new file mode 100644
index 000000000..2b4e36729
--- /dev/null
+++ b/media-video/mpv-mpris/mpv-mpris-0.7.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SLOT="0"
+LICENSE="MIT"
+IUSE="+autoload test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/mpv:=[cplugins,libmpv]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ newlib.so mpris.so ${PN}.so
+ use autoload && dosym -r /usr/$(get_libdir)/${PN}.so /etc/mpv/scripts/mpris.so
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! use autoload; then
+ elog
+ elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
+ elog "You have to activate it manually by passing"
+ elog " '${EPREFIX}/usr/$(get_libdir)/${PN}.so'"
+ elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
+ elog "config directory."
+ elog "Alternatively, activate the autoload use flag."
+ elog
+ fi
+}