aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Donofrio <justin026@protonmail.com>2024-08-14 23:09:44 -0400
committerJustin Donofrio <justin026@protonmail.com>2024-08-14 23:09:44 -0400
commitb5c1f62ce66a7b9ce0884daa3b89a7b6dbc85dd5 (patch)
tree504f80bbe7000bda7843b240d17fef92ac5a53b7 /media-video
parentnet-p2p/monero: add 0.18.3.4 (diff)
downloadguru-b5c1f62ce66a7b9ce0884daa3b89a7b6dbc85dd5.tar.gz
guru-b5c1f62ce66a7b9ce0884daa3b89a7b6dbc85dd5.tar.bz2
guru-b5c1f62ce66a7b9ce0884daa3b89a7b6dbc85dd5.zip
media-video/stremio: new package, add 4.4.164
Signed-off-by: Justin Donofrio <justin026@protonmail.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/stremio/Manifest1
-rw-r--r--media-video/stremio/metadata.xml11
-rw-r--r--media-video/stremio/stremio-4.4.164.ebuild56
3 files changed, 68 insertions, 0 deletions
diff --git a/media-video/stremio/Manifest b/media-video/stremio/Manifest
new file mode 100644
index 000000000..7ef9bb334
--- /dev/null
+++ b/media-video/stremio/Manifest
@@ -0,0 +1 @@
+DIST server.js 6029535 BLAKE2B 222f8f25d12acf3dae0b861e8fdd01ad29aacb9d46ee381faeb29442eb7f0b21002b6f05f818ed7fc9450e7f22d7afd00c08cf4fd171b7e15949d19d878dee86 SHA512 dbd540c3cf88fd53b36fe424f1fb146cb46c41360d7bf35cdb6ade40d34fb1e93aa33c9b1e3a79ff7a74e6f8202fe3407c9ab28878cfd5a5e373ac5a963fe5c0
diff --git a/media-video/stremio/metadata.xml b/media-video/stremio/metadata.xml
new file mode 100644
index 000000000..2f1516048
--- /dev/null
+++ b/media-video/stremio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>justin026@protonmail.com</email>
+ <name>Justin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Stremio/stremio-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/stremio/stremio-4.4.164.ebuild b/media-video/stremio/stremio-4.4.164.ebuild
new file mode 100644
index 000000000..e5db9b122
--- /dev/null
+++ b/media-video/stremio/stremio-4.4.164.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop git-r3 qmake-utils xdg
+
+DESCRIPTION="Stremio is a modern media center for your video entertainment."
+HOMEPAGE="https://github.com/Stremio/stremio-shell https://www.stremio.com/"
+SRC_URI="https://dl.strem.io/server/v${PV}/desktop/server.js"
+
+EGIT_REPO_URI="https://github.com/Stremio/stremio-shell.git"
+EGIT_COMMIT="v${PV}"
+EGIT_SUBMODULES=( '*' '-test-*' )
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="bindist mirror test strip"
+
+RDEPEND="
+ gnome-base/librsvg
+ dev-qt/qtquickcontrols
+ dev-qt/qtopengl
+ dev-qt/qtwebengine:5
+ media-video/ffmpeg[network]
+ media-video/mpv
+ net-libs/nodejs[ssl]
+"
+
+src_compile() {
+ eqmake5
+ emake -f release.makefile
+}
+
+src_install() {
+ insinto /opt/stremio
+ doins build/stremio
+ doins "${DISTDIR}"/server.js
+
+ dosym -r /usr/bin/node /opt/stremio/node
+
+ dosym -r /opt/stremio/stremio /usr/bin/${PN}
+ domenu smartcode-stremio.desktop
+ local x
+ for x in 16 22 24 32 64 128; do
+ newicon -s ${x} icons/smartcode-stremio_${x}.png smartcode-stremio.png
+ done
+
+ fperms +x /opt/stremio/stremio
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}